View Full Version : Cannot access desktop?

September 28th, 2013, 06:40 PM
Hey everyone,
I recently updated from Ubuntu 12.04 to Ubuntu 12.10. When it was finished updating, I restarted my computer. Everything was working fine and dandy, until it came to rebooting. It rebooted normally at first, then the backlight shut off and the screen was totally black and not responding to anything. I rebooted a few more times, and a screen reading "Ubuntu 12.10 thinkpad-ThinkPad-T43 tty2" appeared and asked for my password. The password was not correct, but I was able to reset it. I can now log in, but it just looks like command line. I can't access my desktop. Any advice? Also, would putting the 12.04 ISO files on a flash-drive and booting from that help?


September 28th, 2013, 11:42 PM
a) what do the log files show? Always start there.
b) if you've updated to 12.10 - don't use 12.04 files anymore.
c) newer is not always better. check my signature for why most people should run an LTS like 12.04. Plus, 12.10 is not supported any more (or won't be in a month).

I bet the log files will tell us something useful. Probably related to a GPU driver.

September 29th, 2013, 02:31 AM
How do I view the log files without being able to access the desktop?

September 29th, 2013, 02:36 AM
How do I view the log files without being able to access the desktop?

Here's something funny ... I don't know how to access the log file FROM a desktop. I guess there's a point-n-click method?

I always open a terminal. ;)
http://blog.jdpfu.com/2013/02/11/linux-troubleshooting-101-log-files explains.

September 29th, 2013, 03:35 AM
Ok, so I ran the first command, and the screen filled with stuff like this:

/var/log/Xorg.0.log:[ 16.852] (WW) Warning, couldn't open module fglrx

There were about 15 more lines almost identical to that, except words like "ati, vesa, modesetting", and "fbdev" were sometimes in the place of "fglrx"

September 29th, 2013, 03:51 AM
fglrx is the proprietary ATI/AMD GPU driver. Whenever a new kernel gets installed, you may need to reinstall and re-initialize this driver.

Try this:

sudo apt-get --reinstall install fglrx
export DISPLAY=:0

Then reboot.

September 29th, 2013, 01:19 PM
Ok, when I run the first command, an error message appears:

"Some packages could not be installed. THis may mean that you have requested an impossible situation or if you are using the unstable distribution that some required packages have not yet been created or been moved out of Incoming.
The following information may help you resolve the situation:

The following packages have unmet dependencies:
fglrx : Depends: xserver-xorg-core (>= 2:
E: Unable to correct problems, you have held broken packages."

September 29th, 2013, 02:05 PM
By chance, did you install any .deb packages directly or add any PPAs?
Scratch that .....
sudo apt-get --reinstall install fglrx

I doubt it will work,but that seems to be the issue. Are you ok without a GUI for a little bit? Comfortable in the shell?

September 29th, 2013, 07:49 PM
Hmmm....yet another error message:

E: Command line option 'r' [from -reinstall] is not known.

BTW, thanks for helping me with this!

September 29th, 2013, 08:05 PM
OK, so I booted into tty1, and a notification came up saying that Ubuntu 13.04 was available, and that I could run do-release-upgrade to upgrade to it. Should I upgrade, or would it mess my computer up even more?

September 29th, 2013, 10:38 PM
dash - dash - ... two of them. Not 1.
If you are running 12.10 - yes, you should update to 13.04.
If you are running 12.04 - NO, you should wait for 14.04 to update and always, always, always run an LTS release. IMHO.

September 29th, 2013, 11:15 PM
So, should I solve the blank-screen problem and then update, or before?