View Full Version : [SOLVED] 13.04 install, can't run X server, ATI Radeon black screen

September 22nd, 2013, 04:08 AM

I'ce recently had some issues with booting into a desktop with Ubuntu 13.04. I had a triple boot of Windows 7 (for gaming, once I can play all my games on Linux I'll switch completely), Ubuntu 12 (developing for a particular server), and Ubuntu 13.04. I hadn't touched 13.04 for some time, but yesterday I tried booting into it. It failed, but as I didn't have much on it I decided to do a clean reinstall, removing Ubuntu 12 while I was at it as I no longer needed it. I used a USB stick with Ubuntu 13.04 on it to boot to the live installation, and proceeded to install it. After messing around with GRUB (ended up using boot repair to get that working correctly) I managed to start the booting of 13.04 again. However, it failed at a purple screen with the Ubuntu logo and five red dots (not switching to white like usual).

Using recovery mode, I was able to update everything, via the root terminal prompt of recovery mode. Still no success.

After searching extensively, I installed the proprietary ATI graphics library, fglrx. A reboot resulted in a black screen with a small terminal style cursor in the top left corner. It wasn't blinking. Ctrl-Alt-F1 didn't start any tty terminal, and a "blind" login didn't work. Changing the GRUB boot options to nomodeset, radeon mode to 0, both did not work. I could replace quiet splash with text to get a text login, from which I tried startx, service lightdm start, and installed and attempted to run GDM. All had the same effect of a black screen with a cursor and no responsiveness.

Not sure where to go from here. It's a little strange, as Ubuntu 13.04 did work previously for the short time I used it. I'm booting from an SSD, but I don't think that would cause these problems (I've looked at the LightDM and SSD booting problems but haven't yet tried the solutions, as they don't seem to completely freeze up like I have currently).

September 24th, 2013, 09:58 AM

September 24th, 2013, 12:23 PM
I have managed to fix it. I was booting the USB into UEFI mode, which successfully ran. I noticed that when booting into Legacy mode (the USB that is), the same problem happened for the LiveUSB (black screen, couldn't get it running). So I then created an EFI partition (booted into the LiveUSB in UEFI mode, and used GParted to create a Fat32 200MiB partition with the boot flag), and used Boot Repair to use the new partition as the EFI partition. Then I rebooted and a "new drive" appeared on the BIOS with a UEFI symbol on top. Booting into that allowed me to select Windows 7 or Ubuntu, and Ubuntu worked correctly from there on. My googlefu is strong with me!