View Full Version : [SOLVED] ubuntu and windows boot fails

September 14th, 2013, 02:39 AM
I am trying to install ubuntu 12.04 along side windows 8 on my new computer.
when ubuntu failed to boot (i get lots of messages too fast to read saying things like "unable to read config index scripter broken start error -71" or something, then it tries to go into low graphics mode, fails, and says broken pipe) after instalation i followed the steps at https://help.ubuntu.com/community/Boot-Repair.
fixed nothing, but now windows wont boot.
so, as instructed, i am posting here for help, and it said I should post the following address: paste.ubuntu.com/6104058

thank you for any help.

EDIT: windows magicaly works again

September 14th, 2013, 05:28 AM
When you say Windows works is that from grub menu?

What system is this and what video card/chip do you have?

Have you tried nomodeset? Some systems need other boot parameters instead of nomodeset or in addition to nomodeset.
How to set NOMODESET and other kernel boot options in grub2 - both BIOS liveCD & grub first boot ( also UEFI with grub)
Info on other boot parameters

September 14th, 2013, 03:53 PM
yes windows works from grub.

ok, so now ubuntu will boot into a terminal and display the following messages infinitely

usb 1-7: unable to read config index 0 descriptor/start: -71
usb 1-7: cant read configurations, error -71
hub 1-0:1.0: unable to enumerate usb device on port 7

September 14th, 2013, 04:50 PM
Is this booting from USB?
Are you using a hub or is that just the internal configuration?
Do you have a device in the USB port that is conflicting? Mouse & keyboard should be ok.
Was ISO confirmed to be correct when you downloaded it with md5sum?

September 14th, 2013, 06:21 PM
not booting from usb
no devices in usb ports
iso confirmed correct

September 14th, 2013, 08:59 PM
Some systems require other settings besides nomodeset or changes in UEFI/BIOS settings. These have been posted by other users.

pci=nomsi or ACPI=Off
quiet splash vt.handoff=7 rootdelay=90 reboot=a,w
fixed the problem by adding rootdelay to grub.cfg this allows time for the usb drive to load.

Some systems need these boot parameters usually nomodeset also required.
quiet splash vt.handoff=7 rootdelay=90 reboot=a,w
Some other boot options

Toshiba Satellite P75 intel hd 4600 needed acpi_osi=Linux acpi_backlight=vendor

Toshiba Satellite P50 model number: P50-A-01E Haswell processor
Turned NIC (Integrated Network Interface Controller) off and then booted off of USB. Was NOT an issue with any Linux distro just a quirk of the laptop.

September 14th, 2013, 11:50 PM
ok, I tried all those options, result is:
ubuntu boots to terminal
displays something like "mei" (some numbers) "init hw failure"
and one other line to breifly to read
then repeats the same three messages forever:
usb 1-7: unable to read config index 0 descriptor/start: -71
usb 1-7: cant read configurations, error -71
hub 1-0:1.0: unable to enumerate usb device on port 7

September 15th, 2013, 12:39 AM
What is on port 7?
If you do not know port 7 (I would not), try unplugging different devices. Is anything unusual in one port?

September 15th, 2013, 01:17 AM
as far as i know, nothing is in any port.

September 15th, 2013, 04:27 AM
Do you have the network interface controller in UEFI/BIOS? Try turning that off.

September 15th, 2013, 05:11 PM
turning off does nothing (at least i think its off)

September 16th, 2013, 12:01 AM
I am about out of ideas. What system was this?

September 16th, 2013, 02:49 AM
thats ok, i just went through every step i already tried one more time, and now it magically works!
I am still very confused about this.
Thanks for the help, guess i just needed to do everything 5 times

September 16th, 2013, 04:42 PM
Sometimes you just have to sprinkle the magic pixie dust before executing the command to get it to work. Many time that seems to be the only difference. :)