View Full Version : [ubuntu] Lost 3d Acceleration from 10.4 to 12.4

September 10th, 2013, 05:43 PM
I recently upgraded Ubuntu.
Unfortunately, the upgrade didn't go smoothly.

In particular, I lost all my 3d acceleration and I haven't been able to resolve it.

I have an ATI Radeon 8500 graphic card.
# lspci -nn | grep VGA
01:00.0 VGA compatible controller: Advanced Micro Devices, Inc. [AMD/ATI] R200 [Radeon 8500/8500 LE]

Normally this card is full supported by Unity

Nonetheless, when I run unity_support_test -p, I get
# /usr/lib/nux/unity_support_test -p
OpenGL vendor string: Tungsten Graphics, Inc.
OpenGL renderer string: Mesa DRI R200 (R200 514C) x86/MMX+/3DNow!+/SSE TCL DRI2
OpenGL version string: 1.3 Mesa 8.0.4
Not software rendered: yes
Not blacklisted: yes
GLX fbconfig: yes
GLX texture from pixmap: yes
GL npot or rect textures: yes
GL vertex program: yes
GL fragment program: no
GL vertex buffer object: yes
GL framebuffer object: yes
GL version is 1.4+: no
Unity 3D supported: no

Any idea appreciated. Thank you.

September 10th, 2013, 07:46 PM
Unity needs OpenGL 1.4 or newer and that card supports up to OpenGL 1.3, so that card won't work for the Unity 3D interface. You're not missing out on much in my opinion, Unity is just awful. You might consider LXDE or Xfce which are lighter weight than Unity and run better on older hardware.

September 11th, 2013, 04:21 AM
I installed MATE (based on GNOME 2) instead and I got it to work with Compiz.
Everything is back including the 3d acceleration and the cube.

September 11th, 2013, 05:30 PM
The 3D acceleration never went away, the card was just too old to support the OpenGL version requirement of Unity. The 3D acceleration would've worked in other applications just fine even if Unity complained about it. I'm glad it's working better for you now. MATE is pretty nice!

September 11th, 2013, 08:29 PM
+1 for MATE and the win.