View Full Version : desktop graphic problem after upgrading Kernel

September 9th, 2013, 09:10 PM
i am using ubuntu 12.04.3 64bit. i knew in updating from 12.04.2 to 12.04.3, the kernel does not upgrade, so i decided to upgrade kernel using following commands:

sudo apt-get install --install-recommends xserver-xorg-lts-raring
sudo dpkg-reconfigure xserver-xorg-lts-raring
know, my desktop faced with some graphical problems as you can see in following screenshots:

http://upit.cc/t/a66e605d.png (http://upit.cc/i/a66e605d.png)

http://upit.cc/t/41d1fdff.png (http://upit.cc/i/41d1fdff.png)

http://upit.cc/t/20c6d48d.png (http://upit.cc/i/20c6d48d.png)

i ran glxgears test and saw the average FPS decreased from about 370 to about 120 but amasingly the desktop responsiveness and speed has been improved.

do you know what is the problem and how can i solve that?
My laptop graphic card is NVIDIA Geforce 8400m GS, CPU: Intel Core2due.

September 10th, 2013, 05:16 AM
i want to add that this problem most of tim shows utself in web browsers such as firefox and chrome.
in desktop environment, most of time i do not have any problem but sometimes name of files and window titles become corrupt that shows the problem only affect fonts in the desktop itself.
please guide me to solve the problem.

September 10th, 2013, 05:54 PM
Is that the full command you ran to upgrade to the lts-raring stack?
If so, it seems to be missing a few things.
The command should be

sudo apt-get install --install-recommends linux-generic-lts-raring xserver-xorg-lts-raring libgl1-mesa-glx-lts-raring


September 11th, 2013, 03:17 PM
i ran your suggested command right now and nothing new installed.

sudo apt-get install --install-recommends linux-generic-lts-raring xserver-xorg-lts-raring libgl1-mesa-glx-lts-raring
Reading package lists... Done
Building dependency tree
Reading state information... Done
linux-generic-lts-raring is already the newest version.
linux-generic-lts-raring set to manually installed.
libgl1-mesa-glx-lts-raring is already the newest version.
libgl1-mesa-glx-lts-raring set to manually installed.
xserver-xorg-lts-raring is already the newest version.
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.

September 11th, 2013, 05:26 PM
Are you using the out of the box/default installed graphics drivers(nouveau), or did you install the nvidia drivers?

September 11th, 2013, 10:42 PM
i am using nouveau.

Mephisto Pheles
September 12th, 2013, 06:52 AM
nouveau killed my 12.04.3 upgrade on xubuntu, I kept getting kernel panic crashes after the update.
Didn't have a clue so I researched some, should be a hardware problem, only ... my Linux Mint runs perfectly,
the only difference was that Mint used the nvidia drivers and xubuntu didn't use proprietary drivers.

Even the ubuntu 12.04.3 fresh install DVD crashes with kernel panics. No way for me to even install it.

After installing latest nvidia drivers, xubuntu is running smooth again and has been for several days in a row.

I'll pass on installing ubuntu regular, probably too heavy for my old box anyway.