View Full Version : [SOLVED] software update

September 8th, 2013, 09:52 PM
Hi, does anyone know how i can update a particular software/application without using the conventional "sudo apt-get update" on ubuntu 13.04 because i realised Canonical does not provide updates for some applications

September 8th, 2013, 11:00 PM
Software such as?

September 8th, 2013, 11:15 PM
Do you mean upgrading to newer versions of said software?
(ala libreoffice 3.5> libreoffice 4.1)
Then yes, Ubuntu devs don't provide those for some software.
They like to freeze the versions per their version of Ubuntu.

Ubuntu devs will provide updates for any package you install through the default repositories.
And FYI, running apt-get update doesn't install any updates.It only refreshes the package list.
You need to run apt-get upgrade to actually update.

On 13.04 just run software updater. It automagically runs apt-get update and the lists the availble updates.Which you can then install by clicking OK, or something.

Buntu Bunny
September 9th, 2013, 12:55 AM
If you've the software's PPA, then you should be able to sudo apt-get for updating your software list and upgrading packages.

September 9th, 2013, 10:25 AM
@ajgreeny ubuntu swc has only librecad 1.0.2+nolibs-1build1 but i want upgrading it to 2.0.0 and I dont even know how to get the software's PPA to upgrade it

September 9th, 2013, 05:35 PM
You can try adding the ppa (https://launchpad.net/~librecad-dev/+archive/librecad-daily) to your software sources by following the instruction at the link.

Be warned that it is beta software, and a daily build, so there may be a few bugs, but it is worth a try.

sudo add-apt-repository ppa:librecad-dev/librecad-dailyshould do it for you, then update and upgrade.

September 10th, 2013, 07:55 AM
I tried it and it worked like charm, thanks alot :D

September 10th, 2013, 01:52 PM

Can you go to Thread Tools at the top of the thread and mark this problem as SOLVED.