View Full Version : [SOLVED] missing menu bar and Unity bar after upgrade to 13.04

August 27th, 2013, 02:07 PM
Hello all,

I've recently updated my ubuntu system from 12.04 to 12.10 and directly after that to 13.04 and now I got into trouble :mad:.
I miss the main menu and the left Unity bar.

I already had same problem after update to 12.10 but that helped:

sudo add-apt-repository ppa:makson96/fglrx
sudo apt-get update
sudo apt-get upgrade
sudo apt-get install fglrx-legacy

after update to 13.04 same problem appeared but the above solution didn't helped :(.

I also tried some other ones:
- reinstalling the ATI drivers described on many pages
- resetting the uniy like described in those link http://www.omgubuntu.co.uk/2013/04/how-to-reset-unity-compiz-in-ubuntu-12-10-and-13-04

Nothing helped :/
It seems that it's now worse then on the beginning. when I'm trying to use the first solution (see quotation) i get those errors:

xxx@xxx:~$ sudo apt-get install fglrx-legacy
[sudo] password for rafal:
Czytanie list pakietów... Gotowe
Budowanie drzewa zależności
Odczyt informacji o stanie... Gotowe
Zostaną zainstalowane następujące NOWE pakiety:
0 aktualizowanych, 1 nowo instalowanych, 0 usuwanych i 0 nieaktualizowanych.
2 nie w pełni zainstalowanych lub usuniętych.
Konieczne pobranie 0 B/66,5 MB archiwów.
Po tej operacji zostanie dodatkowo użyte 8192 B miejsca na dysku.
(Odczytywanie bazy danych ... 271652 pliki i katalogi obecnie zainstalowane.)
Rozpakowywanie pakietu fglrx-legacy (z .../fglrx-legacy_2%3a8.97.100.7-makson1~raring3_amd64.deb) ...
One or more files have been altered since installation.
Uninstall will not be completed. See /etc/ati/fglrx-uninstall.log for details.
dpkg: błąd przetwarzania /var/cache/apt/archives/fglrx-legacy_2%3a8.97.100.7-makson1~raring3_amd64.deb (--unpack):
podproces nowy skrypt pre-installation zwrócił kod błędu 1
Brak raportu programu apport, ponieważ osiągnięto limit MaxReports
Wystąpiły błędy podczas przetwarzania:
E: Sub-process /usr/bin/dpkg returned an error code (1)

Ubuntu 13.01
laptop: compal khlb2
ATI Mobility Radeon HD 4650 – 512 MB
Intel Core 2 Duo T9400 2.53 GHz

I'm waiting for your support.


August 28th, 2013, 11:48 AM
Nobody who could help :(?

August 28th, 2013, 06:41 PM
You could try changing the video driver but how can you do that when you cannot open System Settings? Right click the desktop background image. Does a menu appear? Select Change Desktop Background. That will open the Appearance menu which is part of System Settings. Click All Settings and then load Software and Updates and open the Additional Drivers tab. Wait a few minutes while the utility searches for drivers and then experiment.

As you have worked out for yourself, it is a video driver issue.


August 28th, 2013, 09:03 PM
I've fixed it :)

how?to be honest, hard to say :/.
ButI will try to describe all the done steps.

1.I've fixed the fglrxproblem in the packages. (like recommended by apt-get)
2. commandas root: "unity-reset"
3. commandas root: "unity"
And the menus are back :)
butafter restart not the problem reappeared...
4. do step 2,3 asstandard used restart
5. again same like 4 (hot restart - computerfreezes)
6.after restart unity is there again :)

maybe byaccidentbut working

February 20th, 2014, 11:53 PM
Nobody who could help :(?

...$ sudo apt-get install compizconfig-settings-manager
...$ ccsm

in the manager window go to Preferences (left pane) in the profile section select "unity" instead of "Default" in the drop-down menu.

You may also want to:
retick OpenGL and enable Ubuntu Unity Plugin in Ubuntu Unity Plugin option.

Hope it helps.

Worked for me :)