View Full Version : Strange Java errors in chromium-browser after upgrade

August 24th, 2013, 09:35 PM
Hey all,

I recently upgraded from 11.04 to 12.04 (a little late, I know) on my EEE PC so that I could upgrade pepper flash and java in chromium so that my mother could keep playing these horrid, poorly-coded little games on a website called pogo.com. Just today, although the flash-based games still continue to work fine, the java games refused to load altogether giving an error that I MUST upgrade to Oracle Java 7 Update 25 due to necessary security updates.

I followed some instructions online that led to me adding a webupd8 PPA to install the "oracle-java7-installer" package via apt-get. Running "java -version" tells me it's Java 7 Update 25, but chromium still reports the plugin as being out-of-date even after symbolically linking the updated libnpjp2.so to the right directories. When running it from a terminal, the following error shows up whenever I try to load any java applet:

Exception in thread "main" java.lang.UnsatisfiedLinkError: /usr/lib/jvm/java-7-oracle/jre/lib/i386/libnio.so: /usr/lib/chromium-browser/libs/libnet.so: version `SUNWprivate_1.1' not found (required by /usr/lib/jvm/java-7-oracle/jre/lib/i386/libnio.so) at java.lang.ClassLoader$NativeLibrary.load(Native Method)
at java.lang.ClassLoader.loadLibrary1(ClassLoader.jav a:1957)
at java.lang.ClassLoader.loadLibrary0(ClassLoader.jav a:1882)
at java.lang.ClassLoader.loadLibrary(ClassLoader.java :1864)
at java.lang.Runtime.loadLibrary0(Runtime.java:849)
at java.lang.System.loadLibrary(System.java:1087)
at sun.security.action.LoadLibraryAction.run(LoadLibr aryAction.java:67)
at sun.security.action.LoadLibraryAction.run(LoadLibr aryAction.java:47)
at java.security.AccessController.doPrivileged(Native Method)
at sun.nio.ch.Util.load(Util.java:487)
at sun.nio.ch.IOUtil.<clinit>(IOUtil.java:351)
at sun.nio.ch.Util.<clinit>(Util.java:48)
at sun.nio.ch.FileChannelImpl.<clinit>(FileChannelImpl.java:1132)
at java.io.FileInputStream.getChannel(FileInputStream .java:364)
at com.sun.deploy.util.SyncFileAccess.openLockFileObj ect(Unknown Source)
at com.sun.deploy.util.SyncFileAccess.openLockFileInp utStream(Unknown Source)
at com.sun.deploy.config.ClientConfig.loadPropertiesF ile(Unknown Source)
at com.sun.deploy.config.ClientConfig.refreshProperti es(Unknown Source)
at com.sun.deploy.config.ClientConfig.init(Unknown Source)
at com.sun.deploy.config.ClientConfig.<init>(Unknown Source)
at com.sun.deploy.config.PluginServerConfig.<init>(Unknown Source)
at sun.plugin2.main.server.JVMManager.<init>(Unknown Source)
at sun.plugin2.main.server.JVMManager.getManager(Unkn own Source)
at sun.plugin2.main.server.MozillaPlugin.maybeStartAp plet(Unknown Source)
at sun.plugin2.main.server.MozillaPlugin.setWindow(Un known Source)

I was able to find some vaguely similar errors on Google, but every single instance was somebody programming new Java code and having the errors pop up during compilation; nobody else seems to be or have been experiencing this same issue with Oracle Java 7 Update 25. If anybody can give me some leads or info on what I might do (other than completely uninstalling and reinstalling Ubuntu 12.04 and seeing if it suddenly starts working), that would be MUCH appreciated.

August 25th, 2013, 12:33 PM
I've got a similar problem, I've tried all sorts of links and nothing works, I would have thought this should have worked:-

cd /usr/lib/chromium-browser/plugins

sudo ln -s /usr/lib/jvm/java-7-oracle/jre/lib/i386/libnpjp2.so libnpjp2.so

I can see the link in the plugins folder and it points to the right place.

Both Firefox and Opera have found Java 7 Update 25, it will be interesting to see if you get any replies on what we are doing wrong. We are probably are doing something wrong, but I can't see it.

October 3rd, 2013, 05:55 PM
Same problem here after Upgrade from 12.10 to 13.04.

about:plugins shows

Java(TM)- Version: 10.40.2Next Generation Java Plug-in 10.40.2 for Mozilla browsers

Java(TM) Plug-in 10.40.2

Next Generation Java Plug-in 10.40.2 for Mozilla browsers



Plugin is loaded via symlinks in /usr/lib/mozilla/plugins and works absolutely fine in Firefox. Has something changed in Chromium's libnet.so?

"strings /usr/lib/chromium-browser/libs/libnet.so | grep SUNWprivate" returns nothing.

October 25th, 2013, 11:28 AM
Upgrading xUbuntu to 13.10 Saucy with Chromium 29.x makes everything work again. Pity there's no backport or PPA that ports the absolutely recent Chromium versions to 13.04.

November 12th, 2013, 05:12 PM

Today I did a dist-upgrade on my 12.04 (Precise) and I had exactly the same issue with Chromium 30.

I uninstalled chromium-browser packages and installed versión 29 from ppa:chromium-daily/stable:

$ sudo add-apt-repository ppa:chromium-daily/stable
$ sudo apt-get install chromium-browser=29.0.1547.57-0ubuntu0~cm4 chromium-browser-l10n=29.0.1547.57-0ubuntu0~cm4

Now, the applets are working again.


November 12th, 2013, 06:51 PM
I've just submitted a bug: https://bugs.launchpad.net/ubuntu/+source/chromium-browser/+bug/1250550