View Full Version : [ubuntu] can't boot to windows 8 after ubuntu 12.04 LTS installation

July 19th, 2013, 12:53 PM
I have a HP Pavilion Touchsmart laptop which came initially with Windows 8 OS. I disabled the secure boot then, installed ubuntu 12.04 LTS on a separate partition (dual boot). Now I cannot boot windows 8. Selecting the windows 8 option the following error is displayed

error: unknown command 'drivemap'
error: invalid EFI file path.

I ran the boot-repair once but still the same problem persists.
Boot-repair: http://paste.ubuntu.com/5890413 (http://paste.ubuntu.com/5890413)

July 19th, 2013, 01:00 PM
It sounds like you've deleted your windows boot partition, sadly.
The drivemap is so it can load your OS onto memory, if it doesnt exist then you very well may need to re-install windows 8.
Other people on here more experienced with windows 8 might be able to help.

Sorry i cant!

July 19th, 2013, 03:57 PM
If it is Windows 8 that is UEFI. But it sounds like you installed Ubuntu in BIOS/CSM/Legacy mode? UEFI and BIOS write hardware system data differently for system to use so booting from BIOS will not let you boot Windows from grub. Also grub has a bug and writes BIOS boot entries even if Ubuntu is in UEFI mode. You can use Boot-Repair to convert to UEFI or to add correct UEFI Windows boot entries.

Post the link to the BootInfo report that this creates. Is part of Boot-Repair:
Boot Repair -Also handles LVM, GPT, separate /boot and UEFI dual boot.:
You can repair many boot issues with this or 'Create BootInfo' report (Other Options) & post the link it creates, so we can see your exact configuration and diagnose advanced problems.
LighterWeight (Lubuntu based) Boot-RepairCD
Full Ubuntu 13.04 liveDVD or USB Install with Boot-Repair included (for newer computers)