View Full Version : RoundCube - connection to storage failed.

July 18th, 2013, 02:33 PM
Hi All,

I have spent a lot of time reading posts and different websites trying to get Roundcube to work with no luck.
There many threads and posts out there which I have tried, the only install guide that works to the point of successful (web installer tests) results on the web installer is official install instructions below -:


After following the guidelines i still cannot log into Roundcube keep getting 'unable to connect to storage'
The sql database roundcube and usercube user are created and privileges set, so i'm unsure what is causing this issue when the installer webpage gives me green results on my set-up.

setup installed
Ubuntu Server with KUbuntu desktop. 12.04.2 LTS & 4.8.5 KDE
Roundcubemail 0.9.2
Postfix (and postfix admin) email working well.
Courier IMAP
SpamAsssassin, ClamAV, Postgrey, Amavisd

Any advise or help would be most appreciated..

July 18th, 2013, 02:40 PM
Hello kikstart

If you just simply want a good install of roundcube, you can install it automatically via the synaptics package manager.
Just search roundcube in it and all packages required will be shown,just double click the top item and follow the instuctions.

Hope this helps

July 18th, 2013, 03:02 PM
Hi Boab1993,

All packages are installed except postgreSQL, as i'm using MySql.. thanks for the advise.

I have installed previously the downloadable packages (older version of roundcube) and they failed to even work with mysql let alone install correctly.

So I'm at a brick wall in regards to getting this working.. i cannot log into the 'usercube' account in roundcube. Eventually I want to link this into postfix.

July 18th, 2013, 03:17 PM
Excellent, now we know where the problem lies, sadly it looks like its with mySQL
Try entering this as a command in mySQL

CREATE DATABASE roundcubemail;
GRANT ALL PRIVILEGES ON roundcubemail.* TO yournamel@localhost IDENTIFIED BY yourpassword ;


See how that goes

July 18th, 2013, 11:13 PM
I've already done the privileges on the account in mysql.

This guide is basically what I've followed, but the issue is i cannot log into roundcube.


July 18th, 2013, 11:34 PM
I see. It seems to have everything there, only thing id say is it doesn't mention to enter 'FLUSH PRIVILEGES' during rights set-up.
If the only a problem with logging in it can be a number of things.
What kind of email account are you using(Gmail, hotmail, etc)?
It can also be a problem with the SMTP & IMAP configuration

Run through what you did during the setup, the more information the easier it'll be!

July 19th, 2013, 10:19 PM
Thanks for your help Boap1993, most appreciated.

This is the thread which basically is my set-up.


My telnet tests show IMAP is working and i can send and receive email.

Next stage was I then installed Roundcube, I've tried package install of roundcube and also the manually installing latest version from the developers website (obviously customize to my set-up domain / email etc.) The latest/manual install 0.9.2 is better results during testing.

I did have a thought if maybe an encrypted home directory may be causing the issue? as I am running KUbuntu-desktop on Ubuntu server.

I have recreated the roundcube database and account and set the privileges and imported the tables, but again i get the same results..

Any ideas or thoughts?

July 19th, 2013, 11:32 PM
Thank you for the appreciation, its always nice to hear feedback!

Its a good hunch, it is highly possible an encrypted home folder could be throwing up errors, if you are sending/recieveing mail from your home folder.
Exploring it would be a matter of changing your postfix address to outside your home folder, i.e. root, but this is not advised according to the tutorial you have linked.

If it turns out that is the case, easy way out is to:
Copy all files from your home folder to another folder of any type, just make sure you don't delete it.
Delete the home folder.
Make a new folder called 'home'
Move your the original files back in.

This actually 'un-encrypts' your home folder.

Try it out, it can't hurt. Just make sure to backup.

Since its connection errors, my thoughts are still around configuration files and IMAP etc, I'll look into it a bit more.

If you can get your apache logs up here, it would show some sort of anomaly hopefully

Good luck!