View Full Version : [xubuntu] double to open executable text file

July 8th, 2013, 07:43 PM
I recently switched to xubuntu and I have one simple issue I can't resolve. How do I change the default action to open an executable text file instead of executing it in the file manager(thunar)?

July 10th, 2013, 12:13 PM
you can't. if it's executable, double-click will execute it. you can always right-click -> open with. if going down a submenu is too much, you can assign a thunar custom action, e.g. "Edit", so you only have to right-click -> Edit (or whatever you call the action that opens the file in your favorite editor).

Frogs Hair
July 10th, 2013, 03:32 PM
In Thunar under Edit > Preferences > Advanced you can set to ask each time which displays a dialog to view, run, and so on.

July 10th, 2013, 03:35 PM
Under Edit > Preferences > Advanced, I only see options for how file permissions are propagated and volume management.

Frogs Hair
July 10th, 2013, 06:49 PM
Excuse me , you are correct I get no run dialog in Thunar 1.6.3 . I use the XFCE 4.12 PPA .


July 11th, 2013, 07:33 PM
method of execution is givern here http://askubuntu.com/questions/122428/how-to-run-sh-file

July 12th, 2013, 08:55 AM
dear original poster, i think the last post does not apply to your question.
frogshair already admitted to being wrong, so it comes down to what i said originally.

this is a difference between thunar and nautilus.

i always found the nautilus way confusing (iirc pcmanfm has it too), but if you're used to it...
[for me the best solution would be if double click always opens the file for editing, and i'd have to right click to execute it.]

if you uncheck the executable permission bit on your text file, double click opens it in an editor (or whatever is associated to this kind of file).