View Full Version : [ubuntu] google-chrome.desktop always reverts to default

June 1st, 2013, 08:38 AM
I want Chrome Browser open a window by every computer start. There is the file ~/.config/autostart/google-chrome.desktop where I can change option

Exec=/opt/google/chrome/google-chrome --no-startup-window by removing --no-startup-window parameter. After first reboot it works as expected, a new browser window is open automatically. But after next restart, the file google-chrome.desktop always returns to its default state.

What can I do to edit this file permanently?


June 1st, 2013, 08:43 AM
Hi could you please explain what you want? Do you want Chrome to start automatically each time you log in?

June 2nd, 2013, 03:34 PM
ASAIK Chrome Browser is starting up each time I log in, thanks to the file~/.config/autostart/google-chrome.desktop. What I want is to permanently remove the --no-startup-window parameter, because I want Chrome Browser not only start at log in but also open a new window, so that I won't have to do in manually.

June 2nd, 2013, 08:44 PM
You can try setting the file as immutable.

edit/save your file to your liking, and then run

sudo chattr +i filename
change filename to the actual path and file name.
This will make the file unchangeable, hopefully.

June 5th, 2013, 07:26 PM
It works, thanks :)