View Full Version : [xubuntu] 13.04 No Video Thumbnails in Thunar

May 19th, 2013, 08:17 AM
First, some background.

I was running 12.10, which was a normal installation of Ubuntu. I then installed XFCE4 alongside it. In that configuration, Thunar could load all the thumbnails that Nautilus created, and it could also generate new thumbnails on brand-new files itself.

Then I did a clean install of Xubuntu 13.04, and nothing.

I installed gstreamer-bad, gstreamer-bad-multiverse, and gstreamer-ugly, and still nothing. I installed tumbler-plugins-extra, and ffmpegthumbnailer, and nothing. I went to delete the ~/.thumbnails directory to see if that would help, and the ~/.thumbnails directory doesn't even exit.

I logged out and back in. I even rebooted. And still, no video thumbnails in Thunar. Any ideas?

I should add that I'm using the 64-bit version.


I think what we might be dealing with here is a good old-fashioned bug.

I did another clean install and before even doing any system updates, I downloaded a video. When I browsed to the video in Thunar, I got a crash report from tumblerd. Of course it wouldn't submit the crash report because my system wasn't updated. So I updated my system and rebooted. The crash report was gone, but still no thumbnails.

I then tried to play the video and Parole wanted to download gstreamer-ffmpeg to do so, so I let it. Then the video played fine, but still no thumbnails.

I went to:


And ran "tumblerd" there directly. It ran okay but as soon as I then opened a directory with video files in it in Thunar, tumblerd crashed with this message:

(tumblerd:1910): GLib-GObject-CRITICAL **: g_object_set: assertion `G_IS_OBJECT (object)' failed

(tumblerd:1910): GStreamer-CRITICAL **: gst_element_set_state: assertion `GST_IS_ELEMENT (element)' failed

(tumblerd:1910): GStreamer-CRITICAL **: gst_element_get_bus: assertion `GST_IS_ELEMENT (element)' failed

(tumblerd:1910): GStreamer-CRITICAL **: gst_bus_timed_pop_filtered: assertion `GST_IS_BUS (bus)' failed
Segmentation fault (core dumped)

I then downloaded a variety of files... videos of different codecs and different types of image files... and put them in a directory together. I ran tumblerd again and went to the directory. The thumbnails generated on the first few image files but then when the process hit the video files tumblerd crashed again and didn't process any of the remaining graphic files. Out of curiosity I then went into the /usr/lib/x86_64-linux-gnu/tumbler-1/plugins directory and deleted the tumbler-gst-thumbnailer.so file. Ran it again and this time all the image files had their thumbnails generated properly. The video files were skipped over, but no crash.

Then I installed the tumbler-plugins-extra package to use ffmpeg to generate the thumbnails. All of the video files had their thumbnails generated properly except for the .ogv file, and all of that with no crash. Then I uninstalled tumbler-plugins-extra, re-installed tumbler to get the gst-thumbnailer file back and tested it again. Once again we were back to crashing with no video thumbnails.

So, it seems that the version of tumbler that comes with Xubuntu 13.04 is buggy and will not generate video thumbnails using GStreamer. GStreamer can decode the files fine as you can play videos using the GStreamer libraries, but tumbler simply will not generate the video thumbnails with GStreamer as the back-end.

May 19th, 2013, 12:16 PM
You can submit a bug report manually by running:

apport-bug tumbler
...from a terminal window. Post back the bug number and I'll subscribe to it as well.

May 19th, 2013, 04:26 PM
Beside on segfaulted Tumbler of Xfce 4.10 within Xubuntu 13.04, the culprit is the env variable (see http://docs.xfce.org/xfce/thunar/tumbler) :

Does respond null or permission denied. You can't

mkdir -p $XDG_CONFIG_HOME/tumbler
cp /etc/xdg/tumbler/tumbler.rc $XDG_CONFIG_HOME/tumbler/
This variable is misconfigured or not configured; if you try to force it like:

export XDG_CONFIG_HOME=$HOME/.config
mkdir -p $XDG_CONFIG_HOME/tumbler
cp /etc/xdg/tumbler/tumbler.rc $XDG_CONFIG_HOME/tumbler/
it "works" but the system became really unstable; this happen also with the last tumbler available on PPA https://launchpad.net/~xubuntu-dev/+archive/xfce-4.12 that is not segfaulted

Really bad.

May 20th, 2013, 02:35 AM
Here's the bug report:


So the bug is #1181890.