View Full Version : 12.4 Can't move slider to allocate size of partition

May 3rd, 2013, 04:08 PM
12.4 64 Bit Version runs fine when not installed but on trying to instal it comes up asking how much HDA space I want to allocate to it. I can see where it has set the division but the mouse will not move the slider. Am trying to instal on a 2011 tower with Intel HD graphics but am using a monitor thats 9 years old ie a LM-171 and think it may be a problem with something either built into it to use with the Nvidia graphic card which was on the old machine. When I ran Gentoo had to regularly undo Nvidia driver update and revert to one lower than 173 Oldpeter

May 3rd, 2013, 04:48 PM
This problem has nothing to do with the video adapter or the video driver. Are you trying to install using the Install alongside option or the Do something else option?

All I can do is guess. You may need to open one of Gparted's menus and select Resize. That may allow you to use the mouse to grab the resize arrows and resize the partition.


May 3rd, 2013, 11:06 PM
In fact, it's all about the partitions on the hard drive. If you described the partition setup, people might be able to help you.

Use the terminal command: sudo fdisk -l

May 4th, 2013, 02:32 PM
Have 2 HDA's and w7 has split the smaller one (1.5T) into two 750 partitions named C and D . Th other one F is almost completely full of data OldPeter

May 4th, 2013, 02:43 PM
Do not use the slider to resize windows, especially not the system partition. Use windows Disk Management. You need to create unallocated space (not belonging to any ntfs partition). How you do that, whether by shrinking some ntfs partition or by deleting it, it's your choice.

Windows can complain when linux toold resize its partition, That's why use Disk Management and reboot windows few times to do any disk checks it might need after the resize.

Once you have unallocated space on any of the two disks, start the ubuntu installer and install.

Mark Phelps
May 4th, 2013, 03:40 PM
You didn't say anything about "drive" E:, but if you do already have four primary partitions -- do NOT attempt to create another, especially using Windows Disk Management. It WILL let you do that, unfortunately, but in the process, it will convert all your partitions into Dynamic Disks -- something you do NOT want to do!

May 4th, 2013, 05:04 PM
I used Partition Magic to reduce the size of D to 350GB leaving 341GB unallocated and ran a few times and all looks fine but on trying to instal Ubuntu again it only gives me an option to reduce the size of the full (except for about 100mb) 2tb F disk and does not appear to be seeing the smaller !.5 disk with the unallocated space. Initially the machine only had the 1.5T disk and hence C and D OldPter

May 4th, 2013, 05:39 PM
1. If the disk has been used in fakeraid before, and it still has meta data on it, the ubuntu installer will ignore it until you remove the meta data.

2. If it had gpt table earlier and you switched to msdos using windows, it doesn't delete the backup gpt table as it should be, and that confuses linux because it can see two different tables.

3. If the disk is Dynamic instead of Basic.

That's just few common reasons why the installer would ignore a disk. There could also be some error in the partition table that windows ignores, but linux doesn't, so it's not letting you use the disk. Just because windows seems to be using the disk as normal, it doesn't mean all is good with it. It often ignores errors.

Mark Phelps
May 4th, 2013, 09:23 PM
IF you want detailed advice, then you need to follow the instructions in Post #2 -- and post the output of that command. That will allow us to see the partition layout on the drive and we won't have to continue guessing what you have.

May 5th, 2013, 04:36 PM
After I replied yesterday realized what the problem was that Ubuntu was only seeing the 2 tb disk which had no spare room hence the slider would not move.

This Acer tower was purchased new last year and came with W7 installed and the 1.5 TB disk formatted. Had not touched the partitions until yesterday (C & D) when reduced the size of the second partition (D ) by 350GB to leave 350GB unallocated for Ubuntu. The DVD is at E. Then later I mounted the 2TB drive in the one 3.5 Acer easy-swap HDD bay in the front of the machine under the dvd. That 2TB disk had been created under Gentoo but have not previously run any Linux application on this machine.

You appear to need a fdisk listing but under the Ubuntu trial version one does not have use of a terminal (unless there is a way to provide it) so I clicked on " Go" on the top of the screen then "Computer" and it tells me I have 4 Hard drives which is completely wrong and three were listing the same area??? They were a 1.5 TB Named Acer , a 1.5 TB named Data, a 1.5 TB named System Reserved and a 2.tb Named Peter .Properties gave me nothing except they were all Octct-stream.

I then ran KNoppix and below is the Fdisk listing but would the answer be to just remove the 2TB disk?

Disk /dev/sda: 1500.3 GB, 1500301910016 bytes
255 heads, 63 sectors/track, 182401 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
Sector size (logical/physical): 512 bytes / 4096 bytes
I/O size (minimum/optimal): 4096 bytes / 4096 bytes
Disk identifier: 0x15704c10

Device Boot Start End Blocks Id System
/dev/sda1 1 2481 19922944 27 Unknown
/dev/sda2 * 2481 2494 102400 7 HPFS/NTFS
/dev/sda3 2494 92431 722417664 7 HPFS/NTFS
/dev/sda4 92431 137887 365130752 7 HPFS/NTFS

Disk /dev/sdb: 2000.4 GB, 2000398934016 bytes
255 heads, 63 sectors/track, 243201 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0x2ff5b946

Device Boot Start End Blocks Id System
/dev/sdb1 1 243202 1953512448 7 HPFS/NTFS

May 5th, 2013, 05:34 PM
The 2TB disk has one ntfs partition suing the whole disk. On top of that, it might be a problem since it says it ends at 243202 cylinders and the total of the disk is 243201 cylinder. So this might be an error in the partition table.

The 1.5TB disk now has unallocated space, but it also has 4 primary partitions which is the limit of a disk with msdos table. The ubuntu installer can't create new partitions from the unallocated space because it already has the maximum number of partitions.

May 6th, 2013, 04:04 PM
My version of Windows is Windows 7 Home Premium Home Edition Media Center 6.01.7601 Service Pack 1 64Bt and it only shows me that the system only has two Partitions C & D on the 1.5 disk, the other two partition must be required by Windows internals, there sizes are 19KB and 100KB the other disk only has 4kb unused. As the factory instal used up all the 4 partitions I assume that at present am not able to instal Ubuntu or any other distro using that disk - a pity as I like Linux and Ubuntu in particular as updating is so efficient.

If I try to make space on that 2 Tb disk by transferring files it would upset the indexes have built up so instead will just extend the D partition to use the now unallocated area on 1.5

Thanks for your time and advice, it is appreciated OldPeter

ps. Will mark this as closed in a few days if no one else has any bright ideas.:(

May 6th, 2013, 04:22 PM
Just had a thought. If I use wubi does Ubuntu still require it's own partition? My bios is this old and new type (E...) if that matters - had an idea it did with W8 OldPeter:o

May 6th, 2013, 04:52 PM
You can consider converting the sda4 partition in logical, which will then allow you to use the unallocated space behind it for more logical partitions. Ubuntu installs just fine on logical partitions.

Wubi is not a solution since it's only for a short try, not long term use. And especially not for upgrading to future releases. In fact, I think that starting from the latest 13.04 they finally dropped wubi.

If you decide to convert sda4 to logical, I'm not sure whether it will temporarily lose the D: letter, because I've never done that myself. But even if it does, you can easily assing the same letter again in windows the first time you boot it. I am mentioning this in case you have something on that partition that depends on the letter.

In case you want to try this, the best bet is using fixparts from ubuntu live mode. Load the live mode, download and install the .deb package, and then you can call it in terminal with:

sudo fixparts /dev/sda

In the tutorial you have the options listed, and which one is for changing partitions to logical.


May 9th, 2013, 03:15 PM
Thanks for the information and the tutorial, am now half installed - as far as the restart after the initial Ubuntu instal.

I was not sure whether a linux application would download and run when the actual OS was sitting on a CD so decided to change the partition type in W7. And as I already had Mini Tool Partition Wizard Home Edition on the machine ( which is very easy to use) I used it and the D partition did remain within W7 even though it is now a logical partition.

The Ubuntu instal seemed to go fine until it said it needed to restart to finish but restarting or starting only starts W7

I downloaded the up-to-date version of Boot-repair which seems (lubuntu) cumbersome and not yet finished compared with the old KDE version. It recommended I run three terminal commands by inputting them through copy/paste but the copy/paste facility does not work so I typed out the first command sudo chroot "/mnt/boot-sav/sda6" dpkg-config-a but it said it couildnt not find the file - I dont think I made a typing mistake but could have. So tried to use the web facility and wasnt able to discover how it would send an email to, boot.repair@gmail through the only web page it would load so I just did a dump and left it. The dump is at http://pastebin.ubuntu.com/5645070/

Would appreciate some more advice OldPeter

PS This instal it did not come up and ask which OS I wanted as the default starting system or how long to wait before taking the default. I did remove the installation dvd before restarting if that was incorrect

May 9th, 2013, 03:41 PM
Out of what ever reason grub2 didn't install to the MBR. You can add it from live mode. Boot the cd in live mode, open terminal and run:

sudo apt-get install /dev/sda6 /mnt
sudo grub-install --root-directory=/mnt /dev/sda

Reboot and see if that presents you with the grub2 boot menu.

May 10th, 2013, 05:05 PM
Sorry your advice not fully understood -what do you mean by live mode?

When I isert the Ubuntu dvd and say run "trial it", the only other option is "instal it", the resulting desktop does not have a facility to use a terminal so I cant see how I can input Linux commands. I did see that there were some terminals available from Software Centre but if I requested such a download would it be installed in the trial workkspace or the copy of Ubuntu that is already installed and probably already includes a terminal application?

Or did you mean that I should input (type) those commands into the limited lubuntu terminal provided by the "Boot Repair" application?

You did note that the instal didnt ask how much disk space to use or which system I wanted as the default system to boot into or the delay to be applied. Does it matter that this machine has this joint booting facility?

Sorry if I seem a bit thick but I am in my mid 80's which I think is a good excuse

May 10th, 2013, 05:09 PM
Live mode is Try Ubuntu. It has terminal included, just open the Dashboard and search for it. You can search for any application in the search line. Click on the ubuntu logo (first icon) and search for what ever you want.

May 13th, 2013, 04:30 PM
Was positive I had already tried that but I couldn't have as it was so available. I tried your suggestion and got the following result

ubuntu@ubuntu:~$ sudo apt-get install /dev/sda6 /mnt
Reading package lists... Done
Building dependency tree
Reading state information... Done
E: Unable to locate package /dev
E: Unable to locate package

I wondered whether I also needed to use commands like ch-root or something to get to the installed version (would I need a designers password?)

Have been doing some research and also wondered whether my problem is tied up with UEFI and Acer. This is the article have been looking at https://help.ubuntu.com/community/UEFI Need to make sure it is the up-to-date version- the one which on the last page says last updated 25.4.2013

May 13th, 2013, 07:46 PM
Sorry, my mistake. I was probably thinking of something else. :)

That first command should be:

sudo mount /dev/sda6 /mnt

PS EDIT: Fixed the /dev/sda5 error.

May 13th, 2013, 08:16 PM
shouldn't that mount command be for sda6 rather than sda5 as that is a windows partition according to the pastbin output?
not wanting to rain on your parade, just a heads up.

would not the commands for installing grub be:

sudo mount /dev/sda6 /mnt
sudo grub-install --root-directory=/mnt /dev/sda

May 13th, 2013, 09:01 PM
Yes, sorry, another error. :) I better sign out. :)

May 14th, 2013, 04:24 PM
I now see Grub output on starting and can open both OS's so THANKS VERY MUCH - REALLY APPRECIATED OLD PETER

p.s. Have now a problem with using the wireless but will raise that as a new thread.

PPS How do I mark this thread as solved?