View Full Version : [kubuntu] In 13.04 plasma-desktop does not load on start-up

May 2nd, 2013, 10:21 PM
I did an upgrade from Kubuntu 12.10 today and initially bumped into problems with NVidia graphics (I had custom installation of 310 drivers from Nvidia's web page). But after dealing with this and switching to the Nvidia drivers from the repos, I can't get plasma-desktop working automatically after login. I've got a black screen and all the other services running: Krunner, Kwin, network but no Plasma until I hit Alt+F2 and enter 'plasma-desktop' manually. And then it works as usual.

What I tried:
1) Add plasma-desktop in start-up manager in System Settings. I can get apps like Yakuake being loaded at start-up, but not Plasma. It's not there after the reboot.
2) I checked if kde-workspace* is installed (it is).
3) Deleting ~/.config directory
4) Deleting ~/.kde directory
5) Tweaking scripts in /usr/share/xsessions, but they are no different from what I have in other distro running KDE 4.10 where Plasma is fine.
5) Checked this http://forums.gentoo.org/viewtopic-t-852710.html
6) And checked this: https://bugs.launchpad.net/ubuntu/+source/kde-workspace/+bug/976397

This issue occurs also for any new user set up in the system. And initially by default they had the mobile KDE interface (Plasma Active). I uninsulated this, but problem still exists and it seems a system wide issue, not just my user preferences. Can someone tell me:
- what's the name of the script which loads Plasma and where it lives in the system?
- what to change there?
- any package to install?

Unfortunately, I can't just reinstall the system from the LiveDVD :-(

June 10th, 2013, 08:39 PM
I had the same problem. I originally installed Kubuntu 13.04. Then I installed the Ubuntu Unity desktop. Everything ran fine for a couple of days. Then, I might have downloaded some updates, or something, but I tried logging in under "KDE Plasma" and it asked for my wallet password, which I provided, then it went black. I was able to see my pointer/cursor, but that was it. Needless to say I reinstalled Kubuntu from the Live USB drive, and downloaded Ubuntu 13.04. Installed that, and all is good with the world.

I tried many different things: updating drivers, installing updates, not installing updates, not updating drivers, yada, yada, yada...I probably tried installing Kubuntu a dozen times!

Nothing worked. My theory is that there was something with the Ubuntu updates that is making the KDE Plasma shell not play nice.

If you find out anything, let me know. Thanks.

June 11th, 2013, 02:09 AM
Not sure if you're having the same issue, but when I uninstalled some unneeded software and replaced nautilus with pcmanfm (default Ubuntu, not Kubuntu), the desktop icons and wallpaper disappeared, and the desktop was not right-clickable. After a lot of searching I realized that to get everything working, I only had to enter

pcmanfm --desktop

However, I obviously wanted this to last even after closing the terminal and after restarting the computer, so I did some looking and learned how to make .desktop files to automatically run on login. Again, not sure if you are having the same issue, but in case you are, here is what I used for my .desktop file (you might need a different command than pcmanfm --desktop)

[Desktop Entry]
Exec=pcmanfm --desktop

I made the file in a text editor (gedit or leafpad) and saved it as /etc/xdg/autostart/pcmanfm.desktop

I may have also added 'pcmanfm.desktop' to a document containing a list of startup files, I don't remember if that was necessary.

For more info on .desktop files see: