PDA

View Full Version : [ubuntu] Bad character encoding in Ubuntu 13.04



play3man
April 30th, 2013, 07:47 PM
I have Ubuntu 13.04 from release, fresh installation. System language is Slovak and character encoding is everywhere correct except numbers in Skype and VLC (only in settings, subtitles are encoded correctly)

In Skype are like this:

[١٩:١٣:١٣]
[١٩:١٣:٢٧]
[١٩:١٣:٤٣]
[١٩:١٤:٣٣]

And in VLC

٦ or ٧

So it is the same encoding like in Skype...

Here is a terminal output

play3man@play3man-Extensa-5630:~$ locale
LANG=sk_SK.UTF-8
LANGUAGE=sk:en
LC_CTYPE="sk_SK.UTF-8"
LC_NUMERIC=sk_SK.UTF-8
LC_TIME=sk_SK.UTF-8
LC_COLLATE="sk_SK.UTF-8"
LC_MONETARY=sk_SK.UTF-8
LC_MESSAGES="sk_SK.UTF-8"
LC_PAPER=sk_SK.UTF-8
LC_NAME=sk_SK.UTF-8
LC_ADDRESS=sk_SK.UTF-8
LC_TELEPHONE=sk_SK.UTF-8
LC_MEASUREMENT=sk_SK.UTF-8
LC_IDENTIFICATION=sk_SK.UTF-8
LC_ALL=
play3man@play3man-Extensa-5630:~$

play3man
May 1st, 2013, 07:35 PM
Nobody knows how to fix it?

dankojoffrey
May 17th, 2013, 05:51 PM
I had same issue with qbittorrent, clementine and others... system language is english as well as keyboard, but some apps shows up in slovak...

Output:
LANG=en_US.UTF-8
LANGUAGE=
LC_CTYPE="en_US.UTF-8"
LC_NUMERIC=sk_SK.UTF-8
LC_TIME=sk_SK.UTF-8
LC_COLLATE="en_US.UTF-8"
LC_MONETARY=sk_SK.UTF-8
LC_MESSAGES="en_US.UTF-8"
LC_PAPER=sk_SK.UTF-8
LC_NAME=sk_SK.UTF-8
LC_ADDRESS=sk_SK.UTF-8
LC_TELEPHONE=sk_SK.UTF-8
LC_MEASUREMENT=sk_SK.UTF-8
LC_IDENTIFICATION=sk_SK.UTF-8
LC_ALL=

I had different language settings (english) and regional settings (slovak). I changed slovak to english, logged out and in and now it works fine... Maybe something wrong with slovak translation...

uwabaki
June 2nd, 2013, 12:53 PM
yes, had the same issue, changing regional settings to english fixs it

Inoki
June 15th, 2013, 09:53 AM
A bug report has been filed to fix this: https://bugs.launchpad.net/ubuntu-translations/+bug/1191241

tomasz_svk
June 18th, 2013, 12:25 PM
Workaround here: https://bbs.archlinux.org/viewtopic.php?pid=1215057

Inoki
June 19th, 2013, 08:05 AM
Workaround here: https://bbs.archlinux.org/viewtopic.php?pid=1215057
That won't help it, as I don't have any locale.gen file on my computer. Adding this line into terminal: "sudo gedit /etc/default/locale.gen" only brings up a blank file. Searching for it manually also.

Inoki
June 23rd, 2013, 07:16 PM
This workaround (http://askubuntu.com/questions/310990/borked-encoding-in-ubuntu-13-04-for-slovak-language) fixed it for me.