View Full Version : [all variants] 13.04 UEFI boot problems

April 27th, 2013, 11:12 PM
Note: I've had problems with all variants of *Buntu

Tried Ubuntu Gnome 13.04 and it just hangs during UEFI boot, just a black screen I can type on til it freezes.

So I download Ubuntu 13.04 first, and when i go to boot the live cd through UEFI, it hangs for a bit then spams and after all of that, it finally boots into the live environment. It installs fine, no problems there. Then it goes to boot the installation, and it hangs and has a waiting for root device error, and takes me to a busybox console. after a minute or so, it ALSO spams an modprobe error !, and after it's stops spamming that, i can type "exit" and it goes into ubuntu, and everything seems alright after.

Then Kubuntu 13.04, won't finish installing, it keeps failing at the bootloader deployment, first it was this grub-dummy package, then tried again and then it failed with GRUB-EFI. I really have no idea what to do, Ubuntu 13.04 DOES work, but why am I having these boot problems?

EDIT: Windows 7 also installed through UEFI, is a dual boot with Linux I should mention.

Asus Republic of Gamers Crosshair V Formula Z AMD motherboard
AMD FX-8350
Radeon HD 7870
8GB DDR3-2133
120GB Samsung SSD
1TB Seagate Barracuda
Belkin Wireless N Wifi adapter
Built in audio


April 28th, 2013, 12:53 AM
I do not know AMD/Radeon

But lets check that install looks ok first.

Post the link to the BootInfo report that this creates. Is part of Boot-Repair:
Boot Repair -Also handles LVM, GPT, separate /boot and UEFI dual boot.:
You can repair many boot issues with this or 'Create BootInfo' report (Other Options) & post the link it creates, so we can see your exact configuration and diagnose advanced problems.
Install in Ubuntu liveCD or USB or Full RepairCD with Boot-Repair (for newer computers)

Graphics Resolution- Upgrade /Blank Screen after reboot mega thread - MAFoElffen
How to set NOMODESET and other kernel boot options in grub2 - both liveCD & first boot, but different

April 28th, 2013, 03:21 AM
Actually did a secure erase on my SSD and tried MBR installation aswell, and it is also doing this same boot problem. It just hangs now, doesn't even try booting into the live cd, through MBR. I'm actually about to try Kubuntu 13.04 again, but on MBR and hopefully it installs right.

EDIT: Nope, same problem. same problem is happening on BOTH MBR (legacy boot) and UEFI boot. And this is just to the live cd. I can't get anything working at all. it ONLY happens with 13.04, not 12.10 or 12.04. Kubuntu 13.04, just hangs at the Kubuntu logo, but UEFI boot, it just can't write the bootloader. :/ I really don't know why its doing this. I didnt have any problems with any of the daily builds, or beta builds. sigh.


April 28th, 2013, 01:58 PM
bump. I really wanna use Ubuntu 13.04 or something. Whats up with 13.04 being the only one having issues? I installed 12.10 just to test, works flawless. Installed Linux mint 14 KDE, works flawless. It can't be my hardware, it has to be something wrong with 13.04 itself and my hardware, since it's the only distro I've had any problems with where I had to resort posting here and askubuntu.

April 28th, 2013, 04:40 PM
Post link to BootInfo report, just to see what it says.

Are any logs generated or are not not able to even start booting?
It may be to the point of a bug report but you really need to narrow it down to kernel, video or whatever else is the issue.

bug reports info on how to do:

April 29th, 2013, 01:41 AM
I formatted my data drive, lost all my data, and now 13.04 boots like it should. But why only 13.04 and not any other distro?

I don't know whats wrong with this release, but it's bad. very bad. and I'm still having problems. it locks up, (i think thats fixed now.) and firefox doesn't save my addons, things keep crashing, freezing. I even went back to 12.04.2 and had problems. I'm probably just going to go back to using Manjaro. Ubuntu just isn't working with my computer/