View Full Version : [ubuntu] 13.04 upgrade stopped halfway, now problems update manager and shutting down

April 27th, 2013, 09:42 PM
Yesterday i tried to upgrade 12.10 to 13.04, but it got stuck during the installment phase. I should have written down, cause now i only vaguely remember where it got stuck... it had 'baubau' or 'paupau' in it.
I restarted the laptop and i do have 13.04, most things seem to work just fine (firefox, LibreOffice, Rythembox), except the update manager and not shutting down anymore, both times it gets stuck.

What should i do? Is there a way to re-install or other ways to fix this?
Please note, that i am quite new at working with Ubuntu, so can you write all commands down?


April 27th, 2013, 09:45 PM
In terminal:

sudo apt-get dist-upgrade

See what it spits back at ya.

April 27th, 2013, 09:46 PM
To try to finish configuring all remaining packages, and fix any broken packages, open terminal and try:

sudo dpkg --configure -a
sudo apt-get install -f

See how it goes after that.

April 27th, 2013, 10:02 PM
Ai, my Ubuntu is in Dutch...

E: Kon vergrendeling /var/lib/dpkg/lock niet verkrijgen - open (11: Hulpbron is tijdelijk onbeschikbaar)
E: Kan de beheersmap (/var/lib/dpkg/) niet vergrendelen. Is deze in gebruik door een ander proces?

-> Couldn't get ///lock-open (11: Source is temporary unavailable)
-> Cannot lock management folder (///). Is there another proces using it?

Does this make any sense or so i have to switch to English? If so, how?

April 27th, 2013, 10:07 PM
To try to finish configuring all remaining packages, and fix any broken packages, open terminal and try:
[code]sudo dpkg --configure -a

when i entered the above, it responded

dpkg: error: dpkg status database is locked by another process

April 27th, 2013, 10:08 PM
Try my commands that I posted, I was few seconds late. You should try that first before any dist-upgrade since you had an interrupted upgrade.

April 27th, 2013, 10:09 PM
I think deleting the file/folder it mentiones should be OK. That could remove the active lock.

April 27th, 2013, 10:13 PM

sudo apt-get install -f had the same response (that i wrote above, in Dutch/tried to translate)

April 27th, 2013, 10:15 PM
Hi Darko, how do i delete that folder?

April 27th, 2013, 10:19 PM
sudo rm -f /path/folder

April 27th, 2013, 10:22 PM
command not found

April 27th, 2013, 10:26 PM
itś not working... command not found

April 27th, 2013, 10:52 PM
rm is a basic command (short for remove). There is no way not to be found. Are you sure you are getting the syntax right?