View Full Version : [SOLVED] Emacs only starts with -nw after upgrade to 13.04

April 25th, 2013, 08:13 PM
After today's upgrade from Kubuntu 12.10 to 13.04, Emacs only starts with "emacs -nw". It's the same for both emacs23 and emacs24. I have tried running with --live-safe-mode and --debug-init, but there's simply no output, and nothing happens. I also tried to purge and reinstall emacs, but no change. What can I do?

April 26th, 2013, 05:04 AM
I just upgraded and I have the same problem. emacs -nw works but ordinary emacs does not.

PaulW2U reports this on kubuntuforums:


Thanks for any help!


May 5th, 2013, 03:49 PM

Had the same problem. This is how i fixed it (btw. I am not sure which parts actually fixed the problem):

- change the GTK theme settings the following way: http://imgur .com/IsWrCn8 (http://imgur.com/IsWrCn8)
- delete all ~/.gtk* files and folders from your home dir.

Hope it works,
Cheers Suem

May 20th, 2013, 09:34 AM
^ I don't have those themes available. Removing ~/.gtk* files did not help.

May 22nd, 2013, 11:59 AM
Did you try running emacs23-lucid, or emacs24-lucid, instead? That works for me (although with a slightly uglier interface).

May 22nd, 2013, 12:48 PM
Did you try running emacs23-lucid, or emacs24-lucid, instead? That works for me (although with a slightly uglier interface).

Not yet. I didn't like the idea of the uglier interface, so I've been using the terminal version. I thought Lucid was XEmacs? I wonder why such a critical bug has not yet been fixed for 13.04.

May 30th, 2013, 01:20 PM
I thought Lucid was XEmacs?

Good point. But actually, when I do "About Emacs" from my emacs (/usr/bin/emacs23-lucid) I get the following message

This is GNU Emacs, one component of the GNU/Linux operating system.

GNU Emacs 23.4.1 (i686-pc-linux-gnu, X toolkit, Xaw3d scroll bars)
of 2012-09-22 on akateko, modified by Debian
Copyright (C) 2012 Free Software Foundation, Inc.

So it's still GNU Emacs, but with another interface.

June 5th, 2013, 05:49 PM
This bug was fixed in the last couple of hours. Both emacs23 and emacs24 are working here on Kubuntu 13.04. :D

See - https://bugs.launchpad.net/ubuntu/+source/emacs23/+bug/1142213.

Depending on what repositories you have enabled the fixed packages may not be available for another seven days.

June 6th, 2013, 10:27 AM
Great! I upgraded gtk2-engines-oxygen, installed emacs23 (and automatically removed emacs23-lucid), and now emacs starts as it should.