View Full Version : Ubuntu 12 help installing off USB stick

April 20th, 2013, 12:05 AM
Hello everybody, how are you?

I have Ubuntu 12.04 (32-bit) installed on a flash drive. I have a problem with installation.

When I boot in desktop PC - no problem.
When I boot in laptop - stuck issue.

It gets stuck on the Ubuntu logo with all the dots filled. When I tried to press F6, all looks good except it fails on "stopping cold plug devices".
The desktop is using the motherboard's graphic card & laptop has a SSD drive.

I'm brand new to Ubuntu so please be precise in hour answers. Thanks :)

April 20th, 2013, 12:48 AM
It seems that is one of many normal shutdown lines. It is shutting down after something else errors? Or is that the only error message.

What video does laptop have. How much RAM? If more than 3GB you probably should use 64bit version, but that probably will not fix your current error.

April 20th, 2013, 06:34 PM
That's the only line that fails. I'm not sure on the laptop's video specs (guessing ATI) but 4GBs of RAM & it is an Asus K53Z-BBR3 & new SSD.
I tried it on my friend's 2 year old Toshiba laptop and it worked without any issues.

April 20th, 2013, 06:58 PM
Some with various Asus have posted these comments:

Asus m4a87td core unlocker feature on usb3 was causing the problem
Asus - Security> I / O interface Security> "New interface card" or so. SET IT TO LOCKED!!!
In the Asus BIOS I selected Advanced Mode>Advanced>SATA Configuration.
Changed IDE Mode to AHCI Mode
Then,when the SATA3G_1 selection appears in the drive list below,select the Enabled option.
set pci=nomsi or other boot paramter

April 20th, 2013, 07:04 PM
Thanks for the info. I'll try it within 48 hours.
Quick ? - the line "Asus - Security> I / O interface Security> "New interface card" or so. SET IT TO LOCKED!!" - is that in BIOS or Windows 7?

April 20th, 2013, 07:22 PM
I assume that is BIOS. And I would think it should be unlocked, but that is what the OP posted.

April 20th, 2013, 07:25 PM
Okay, I'll try ASAP.

April 21st, 2013, 12:54 AM
I kept the USB I/O to unlocked (if I "lock" then it disables all USB ports). I did change SATA. All that but no luck.
So where I had the option to chose "Default, Help, Try..., Install" etc, I pressed "TAB", then typed nosplash noquiet nomoodeset. Then I pressed "Enter" & got it to appear but in a primitive look - like safe mode for Windows. I squeezed Ubuntu to 14GBs & all installed correctly.

Now when I turn the laptop, I see which OS to choose (Ubuntu in spot 0 & Windows 7 in spot 4). After I chose Ubuntu, I heard it "log on" but freezes on all-purple screen.

My question - Do I always need to add "nosplash noquiet nomoodeset" to option while starting Ubuntu? Do I use all 3? What does each do?

Thanks so far!

April 21st, 2013, 04:35 AM
Nomodeset is a default for video. If having issues I remove splash and quiet as that is what hides the boot process and shows the purple screen & logos. I want to see if boot process stops for any reason. That same info is copied into the demesg log file for later review as it does go by quickly.

Nomodeset is just a basic video usually not good quality. I have nVidia and install the nVidia drivers first thing. AMD has its drivers if a newer card and normally Intel just works, but sometimes needs a default to start. If Optimus you then need Bumblebee.
Each has different ways to update.

What video card/chip do you have? There are many threads on each if you want to search also.

April 21st, 2013, 04:10 PM
I have AMD Radeon(TM) HD 6480G

April 21st, 2013, 06:51 PM
I have nVidia, so do not know AMD.

Ubuntu Precise Installation Guide - AMD/ATI
Add Hardware Graphics - ATI: After installing ATI Driver: From QIII
sudo apt-get install fglrx
#sudo aticonfig --initial -f
sudo aticonfig --adapter=all --initial
After reboot to get Catalyst Control Center
sudo apt-get install fglrx-amdcccle


April 21st, 2013, 07:09 PM
Should I try the "sudo..." lines? How do I get a terminal window if I can't get into Ubuntu?

April 21st, 2013, 09:49 PM
That is to install the proprietary drives once booted. I thought they may have some instructions on booting in the trouble shooting link.
I use nomodeset with nVidia, it may now work for you?

Some find only the generic setting works:
Some other settings:

Older Intel video card: i915.modeset=1 or i915.modeset=0 newer: i915.i915_enable_rc6=1
nVidia: nomodeset
Generic: xforcevesa or nouveau.modeset=0
Radeon: radeon.modeset=0

April 21st, 2013, 09:54 PM
Thanks for the tip. I'll try tomorrow. How do I get a terminal window if I can't get into Ubuntu?

April 21st, 2013, 10:15 PM
Sometimes recovery mode will boot, or boot to a command line. But I think the main difference now with recovery mode it that it already has nomodeset. But that is again once installed.

You generally have to add video boot parameters, but some systems require others also.
noapic nolapic noapci noirqpoll nosmp irqpoll
Check BIOS for settings, sometimes those can make a difference:
and/ or try to boot with acpi=off or nomodeset=0 on the boot line

April 21st, 2013, 10:20 PM
Thanks, I'll do my best tomorrow or this week.

April 23rd, 2013, 08:08 PM
Okay, this is where I'm at:

I followed the video (www.youtube.com/watch?v=OTmZYzaxR_k) but used "radeon.modeset=0" & got in.
When I type "additional" into the dash, all I see is user account (I turned Amazon stuff off).

Once I connected to my WIFI, software updater did updates (including Firefox), the asked to restart. Once restarted, I had to do the radeon.modeset=0 again :(

In the mentioned video, she said about additional drivers. When I type "additional" all I see is "user accounts".

How do I check for additional drivers? Why is my graphics not 100% smooth?

April 23rd, 2013, 09:09 PM
Go to System Settings, Under Hardware, you should see Additional Drivers.
You will need to enter your login password.

System Settings are under upper right cog, first item on menu. Or in the launcher on the left.

April 23rd, 2013, 09:13 PM
Okay, thank you, I'll try tomorrow :)

April 24th, 2013, 08:13 PM
I got it all to work!!! :) :) I went into software center, typed "additional drivers" in the upper-right box, installed it & ran it. It found 2 drivers for my AMD graphics card, activated them both, restarted laptop and now all super!!! Thank you! :)

April 24th, 2013, 08:29 PM
P.S. How do I mark this thread as solved?

April 24th, 2013, 08:40 PM
P.S. How do I mark this thread as solved?