View Full Version : Ubuntu install will not detect Hard Drive

April 12th, 2013, 04:28 PM
I am trying to install Ubuntu 12.10 on ASRock A75M FM1 AMD A75 (Hudson D3) (http://www.asrock.com/mb/overview.asp?model=a75m-hvs) with a wd2002fyps hard drive (http://www.wdc.com/wdproducts/library/SpecSheet/ENG/2879-701312.pdf).

I have tried these ISO : ubuntu-12.10-desktop-amd64.iso and ubuntu-12.10-desktop-i386.iso and linux-secure-12.10-64bit.iso

I have tried all three of these ISO using USB install method, and also trying to use a USB-DVD-ROM drive.

Here is the issue, when you get to the screen to pick your HD (during install), nothing shows up, and if you click anything like + or Install it throws an error. The odd things is, if I start gparted the HD shows up fine, I partitioned it as ext4, but I have tried the install with it unallocated / ext2 / ext3. Pics below to make this clear:


Oh, and with the USB install method, I have booted the USB with uefi mode and bios mode. The CD-DVD-ROM only supports booting from bios mode. Either way all the things I've tried give the exact same results I listed above.

Any ideas ?

April 12th, 2013, 04:43 PM
Usually this happens if the disk has been used in fakeraid before and has meta data leftovers. Gparted from live mode will show it OK but the installer is ignoring it thinking it's part of raid array.

If you are NOT running raid, you can try removing the meta data from live mode in terminal with:

sudo dmraid -Er /dev/sda

The above assumes your hdd is /dev/sda, if you boot from usb stick the stick can be sda and the hdd sdb, so simply adjust the command.

If that asks you to confirm removal of meta data, this was the issue. if it says there is no meta data on the disk, then you don't, and the problem is with something else.

April 12th, 2013, 04:49 PM
That worked! I love you and I love Ubuntu forums thanks!!