PDA

View Full Version : [ubuntu] apt-get errors after upgrade to 12.04 server



crazyk4952
April 11th, 2013, 08:35 PM
I upgraded from Ubuntu server 11.04 to 12.04 using

sudo do-release-upgrade -d

However, now I have the following errors with apt-get that I am unable to resolve:

Setting up initscripts (2.88dsf-13.10ubuntu11.1) ...
mkdir: cannot create directory `/dev/shm': File exists
dpkg: error processing initscripts (--configure):
subprocess installed post-installation script returned error exit status 1
dpkg: dependency problems prevent configuration of procps:
procps depends on initscripts; however:
Package initscripts is not configured yet.
dpkg: error processing procps (--configure):
dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of apache2.2-common:
apache2.2-common depends on procps; however:
Package procps is not configured yet.
dpkg: error processing apache2.2-common (--configure):
dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of apache2-mpm-worker:
apache2-mpm-worker depends on apache2.2-common (= 2.2.22-1ubuntu1.3); however:
Package apache2.2-common is not configured yet.
dpkg: error processing apache2-mpm-worker (--configure):
dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of apache2:
apache2 depends on apache2-mpm-worker (= 2.2.22-1ubuntu1.3) | apache2-mpm-prefork (= 2.2.22-1ubuntu1.3) | apache2-mpm-event (= 2.2.22-1ubuntu1.3) | apache2-mNo apport report written because the error message indicates its a followup error from a previous failure.
No apport report written because the error message indicates its a followup error from a previous failure.
No apport report written because MaxReports is reached already
No apport report written because MaxReports is reached already
No apport report written because MaxReports is reached already
pm-itk (= 2.2.22-1ubuntu1.3); however:
Package apache2-mpm-worker is not configured yet.
Package apache2-mpm-prefork is not installed.
Package apache2-mpm-event is not installed.
Package apache2-mpm-itk is not installed.
apache2 depends on apache2.2-common (= 2.2.22-1ubuntu1.3); however:
Package apache2.2-common is not configured yet.
dpkg: error processing apache2 (--configure):
dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of openssh-server:
openssh-server depends on procps; however:
Package procps is not configured yet.
dpkg: error processing openssh-server (--configure):
dependency problems - leaving unconfigured
Setting up mysql-server (5.5.29-0ubuntu0.12.04.2) ...
Errors were encountered while processing:
initscripts
procps
apache2.2-common
apache2-mpm-worker
apache2
openssh-server
E: Sub-process /usr/bin/dpkg returned an error code (1)

Any thoughts on how I can fix this?

ibjsb4
April 11th, 2013, 08:46 PM
Try


sudo dpkg --configure -a

sudo apt-get -f install

crazyk4952
April 11th, 2013, 08:55 PM
Try


sudo dpkg --configure -a

sudo apt-get -f install

Thanks. I tried that and unfortunately, it did not fix the problem.