View Full Version : Live CD in UEFI splashscreen stays black

Aiken Pandora
April 10th, 2013, 08:03 PM
i got this problem, as soon as I start the Linux Live-CD with UEFI, the grub-bootloader loads, but as soon as i try to start Ubuntu the screen just turns black. You hear that the CD-Drive is running but nothing happens and after some time it just stops.
No matter if I try to start with UEFI on a USB-Drive or Live-CD i canīt get beyond the grub2 bootloader...
I tried nomodeset and xforcevesa.

Anyone got an idea?

and i already tried IDE instead of AHCI.

System is:
Gigabyte z77x-UD3H
Nvidia 570GTX (i think, could be an 570 GT to or so)

April 10th, 2013, 08:46 PM
You probably need nomodeset. I have to use it on every live install boot and first boot after install until I get nVidia drivers installed.

At grub menu press e and add nomodeset in place of quiet splash on linux line.

Graphics Resolution- Upgrade /Blank Screen after reboot mega thread - MAFoElffen
How to set NOMODESET and other kernel boot options in grub2 - both liveCD & first boot, but different

Aiken Pandora
April 10th, 2013, 08:53 PM
i tried nomodset before, it doesnīt work. Like xforcevesa.
I also tried it with vga=1280x1024 or other resolutions.

maybe i should add, that starting CD or USB in Bios Mode works perfectly fine.

Aiken Pandora
April 10th, 2013, 09:46 PM
its like nothing happens, after i use F10, the screen just gets black and thats all, even without quiet splash and so one.

Aiken Pandora
April 10th, 2013, 10:31 PM
solved it by myself, the Problem was the Bios, i donīt know what, maybe the Bios-Version, but i got a Dual-Bios System so i changed to the Backup-Bios (never used it, but it got the same settings as my default, except the Backup-Bios still has the Default Bios-Version)