PDA

View Full Version : [ubuntu] Keyboard and mouse not working during installation (Razer keyboard and mouse)



mrcompson
April 6th, 2013, 11:00 PM
While trying to install Ubuntu on my new computer I've run into some peculiar problems with my mouse and keyboard... After trying to install Ubuntu 12.10 64-bit from a usb stick, the keyboard and mouse is completely unresponsive and nonfunctional. This seems strange, because both worked fine in the Mint Linux live boot and on Windows 8. I haven't been able to check if this problem is restricted to my particular keyboard and mouse as I don't have any other ones around in my apartment.

The details:

I have a Razer Deathadder 2013 Gaming Mouse, and a Razer Blackwidow Ultimate 2013 Expert keyboard. The motherboard is a Socket-1155 ASUS Maximus V Formula, which uses UEFI. During boot the keyboard and mouse both light up, but then the keyboard dims as the Ubuntu installer starts. The same problem persists when using the live boot function in Ubuntu. As both worked with Mint Linux (although I did not install Mint, due to the headache of getting it working with UEFI) this seems really strange to me and I'd appreciate some help getting it sorted out if possible. Thanks!

If any needed details are missing from my post, I'll obviously provide that if necessary.