View Full Version : installing 12.04 hard disk not detected

Philip Marlowe
April 6th, 2013, 05:14 PM
i'm trying to install 12.04 on my brand new pc

hard disk info:

created usb with ubuntu iso:
boot ok,
i choose "try ubuntu": everything's ok, desktop appears etc...
then choose "install ubuntu": no way... it says no enough space in the disk

typing on terminal: sudo fdisk -l gives me just the usb drive information, hard disk like it doesn't exist!

while BIOS can see hard disk for sure: it's in the boot option list like PO: WDC500AAKX-0BERMA0 (476940MB) it's him!

other hardware infos:

any suggestion??? thanks

April 6th, 2013, 05:18 PM
Try another port, or another sata cable, just in case.

If the disk never had partition table on it, not sure if you need to write one first. What does parted output in live mode:

sudo parted -l

Philip Marlowe
April 6th, 2013, 05:31 PM
other port, other table:
i don't fell like open pc case, i'm not expert, hope to solve other way, but if you think it's a good try i'll do it.
sudo parted -l
gives me info of the flash disk i used for booting
1 partition of 4037MB

April 6th, 2013, 05:44 PM
Philip Marlowe;

i'm trying to install 12.04 on my brand new pc
Pops to mind - as we see a lot of it here - , is UEFI enabled in bios ??

just a thought

April 6th, 2013, 08:46 PM
When you say brand new, is it a computer you assembled yourself or you bought it? If you bought it, does it have windows preinstalled?

If there is no OS on it right now, go into BIOS and double check whether the SATA Mode setting is set to AHCI. Also, disable UEFI boot if there is an option for that.

Even though bios shows the disk it doesn't seem detected by ubuntu at all. Sometimes boards have sata ports from two different controllers and it can work on some ports but not on other, depending which controller is connected to which sata ports.

It's not even reported as device. Either the disk is bad/faulty, or the controller is not recognized which would be very rare.

April 6th, 2013, 09:35 PM
If the disk has Microsoft Windows on it and the installer says
it says no enough space in the disk then there could be a couple of possible reasons. Windows is using up the 4 primary partitions allowed or Windows is using the disk as Dynamic disks which the installer cannot read. If it is Windows 8 that you have then you will need Ubuntu 12.04.2 or 12.10 or 13.04. These versions will install on a machine with secured boot enabled but 12.04 and 12.4.1 will not. You need to disable secure boot and also fast boot for good measure.


April 6th, 2013, 09:42 PM
But that still doesn't explain why fdisk or parted in live mode don't show the disk as present. The installer might also ignore a disk with raid meta data on it, but at least Gparted and parted in live mode can see it.

Regardless how many partitions you have or free space, it should at least show it in live mode. It's another thing whether it will allow you to install on it, but it has to show it.

Philip Marlowe
April 7th, 2013, 09:50 PM
hi guys thank you everybody, i'm not so expert (and a bit lazy too...) to easily check all you say. i'm starting to follow this ehow (http://www.ehow.com/how_6008732_create-bootable-usb-fdisk.html) to solve my problem, i'll let you know!

Philip Marlowe
April 7th, 2013, 09:54 PM
but i can easily answer to this: components are brand new and assembled by the eshop where i bought it, absolutely no windows installed.

April 7th, 2013, 10:42 PM
Sounds like you will need to take it back under warranty so they can check it out. Or ask them for advice first.

The disk has to be shown. Otherwise there is something wrong with the machine.

Philip Marlowe
April 8th, 2013, 06:18 PM
i tried with gparted: nothing...
i tried with a widows 8 installation: nothing...
only BIOS can see that disk, i'll contact the guys who sold me the assembled pc...

Philip Marlowe
April 13th, 2013, 01:25 AM
onow hd is ok: my uncle changed something on the bios settng. something i'm not able to explain. ubuntu does bad.... it often crashes,apps crashano, system out of service when you go to audio setting... is this normal?

April 13th, 2013, 09:57 AM
Of course it's not normal. You have some issues but I'm not sure it will be easy to detect. Like the problem with the disk, I don't understand what it was and what option in the bios is changed now. It might be hardware related.

Did the installation of ubuntu go fine, without any errors?

You can also try making a new cd on low speed, if you haven't done that so far. The cd for installing an OS should never be burned at high speed, not more than 8x or 10x. Butning at high speed leave small errors even if it says the burn has been verified.

Philip Marlowe
April 13th, 2013, 10:57 AM
problem soved changing bios setting!!!

April 30th, 2013, 07:12 AM
I too have the same problem. When installing Ubuntu 12.04.1 LTS via CD. The installer cannot find the 80GB SATA Hard disk I have in my dekstop. I tried several ways to make the installer detect the hard drive,
1. Used GPARTED and deleted the partitions on the hard drive before installing, No luck.
2. Using GPARTED, created ext4 root partition and swap partition. After this I came back to install 12.04.1. The installer cannot mount the hard disk at the "Installation Type" window though it finds the har disk as "/dev/sda" in "Device for bootloader installation".

I have a doubt. Is the installer directly jumping to "boot loader installation option.
Anyone, please help to solve the problem.

For reference, the output of "fdisk -l" command is

ubuntu@ubuntu:~$ sudo fdisk -l

Disk /dev/sda: 80.0 GB, 80026361856 bytes
255 heads, 63 sectors/track, 9729 cylinders, total 156301488 sectors
Units = sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0x0008f289.