View Full Version : Live CD hangs on black screen

April 3rd, 2013, 11:45 PM
I'm trying to dual boot Ubuntu 12.10 with my current Windows 8 install, but the Live CD gives a black screen with a blinking underscore (no errors or anything, just blank) when I select "Try Ubuntu." I've disabled Fast Boot in my BIOS, Secure Boot is off, and I've tried all of the F6 options, and still nothing has worked. I've also tried both UEFI and legacy booting the Live CD. I have no idea why it's not working.

-Build Info
Intel Core i5-3570K 3.4GHz
Asus P8Z77-V PRO
Samsung 8GB (2 x 4GB) DDR3-1600
Western Digital Caviar Blue 1TB 3.5" 7200RPM HDD
Crucial M4 128GB 2.5" SSD
Gigabyte Radeon HD 7970 3GB

Note: I've only tried the 64-bit disk so far, and I'd like to avoid using the netboot installer if at all possible as my internet connection is quite slow.

April 3rd, 2013, 11:52 PM
Did motherboard include secure boot? Most have not, yet.

Seems more like a video issue. Do you have Intel or your AMD video as boot choice. I think some disable internal or only use internal to boot to get system started.

I have nVidia, so not real familiar with AMD.
Ubuntu Precise Installation Guide - AMD/ATI
Add Hardware Graphics - ATI: After installing ATI Driver: From QIII
sudo apt-get install fglrx
#sudo aticonfig --initial -f
sudo aticonfig --adapter=all --initial
After reboot to get Catalyst Control Center
sudo apt-get install fglrx-amdcccle

You will need to use the 64 bit version of 12.10 or 12.04.2 and from the UEFI menu boot the flash drive in UEFI mode. That way it will install in UEFI mode.
Systems need quick boot or fast boot turned off in UEFI settings. Vital for some systems. Best to backup efi partition and Windows partition first.
Use Windows Disk Tools to shrink Windows main partition, but not to create any new partitions, if installing on same drive.
As of 12.04.2, it is possible to install on UEFI systems with Secure Boot enabled (using signed versions of Shim, GRUB, and the Linux kernel). This is only currently set up for Ubuntu (desktop, alternate, and server) and Edubuntu images due to pressures of time; we expect to enable it across the entire Ubuntu family for 12.04.3. Details:

April 4th, 2013, 12:03 AM
The motherboard includes secure boot, but it's disabled.
I'm not sure whether Intel or AMD is used for boot, I didn't see that as an option anywhere. But my graphics card is AMD. I don't even get into a live system though, I get a black screen before I reach that. Also, I've tried nomodeset and that doesn't seem to make a difference.

April 4th, 2013, 12:19 AM
Some of the new motherboards with i-series processors need other boot parameters also.

Graphics Resolution- Upgrade /Blank Screen after reboot mega thread - MAFoElffen
How to set NOMODESET and other kernel boot options in grub2 - both liveCD & first boot, but different

Not sure if a different brand might need similar settings?

Gigabyte GA-X79-UD3 with I7-3820
Needed F6 to set ACPI=Off.and nomodeset

dual boot efi windows and efi linux
[SOLVED] UEFI Boot Problems Asus
quiet splash vt.handoff=7 rootdelay=90 reboot=a,w
MSI UEFI bug work around A75MA-G55 UEFI boot entries disappear
[SOLVED] Win 7, Natty dual boot on UEFI sort of working

April 4th, 2013, 01:06 AM
Setting acpi=off and nomodeset on the F6 menu actually brought up the Ubuntu loading screen with the four dots for once, which is as far as I've gotten, but restarting and doing it again didn't reach the loading screen. The boot options didn't work either.

April 4th, 2013, 03:09 AM
I updated my BIOS and tried again a few more times, and one of the times I got this error, with nothing else on the screen:

udevd[128]: timeout 'ata_id --export /dev/sr0'

Don't know if that is of any importance at all.

April 4th, 2013, 04:46 AM
Some with BIOS and maybe UEFI have had settings that cause issues. Like enabling a floppy drive in BIOS, but having no floppy. Or having a blank CD in drive but system cannot read it.
Or maybe secure boot on and it cannot boot a DVD?

April 4th, 2013, 11:23 PM
Okay, I managed to get it installed. It was the optical drive, I unplugged it and it installed just fine.