PDA

View Full Version : [ubuntu] 10.04 LTS and Have a Bad Signature



oldefoxx
March 28th, 2013, 09:32 PM
Something is slightly hosed in my update process. I tried to use the Update Manager or apt-get update, and I get a notice that I have a bad signature. I think it is related to VirtualBox. Anyway, here is the response I get with apt-get update:

Reading package lists... Done
W: GPG error: http://us.archive.ubuntu.com lucid Release: The following signatures were invalid: BADSIG 40976EAF437D05B5 Ubuntu Archive Automatic Signing Key <ftpmaster@ubuntu.com>

What do I do to fix this?

papibe
March 28th, 2013, 09:55 PM
Hi oldefoxx.

Take a look at this tutorial (http://askubuntu.com/questions/198371/apt-encounters-errors-with-bad-gpg-keys) on how to solve it.

Let us know how it goes.
Regards

oldefoxx
March 29th, 2013, 01:40 AM
I used the process in the tutorial and I got back a new sugnature key. But when I try apt-get update again, it comes up with the same error and showing the original signature key. I may have added one, but I did not get rid of the old one.

Bashing-om
March 29th, 2013, 02:15 AM
oldefoxx;

Maybe try it like this ??

sudo apt-key adv --recv-keys --keyserver keyserver.ubuntu.com 40976EAF437D05B5
The format is slightly different than that in askubuntu's thread.

just try'n to help

mrgs
March 29th, 2013, 03:20 PM
The plain and simple approach is to leave 10.04 and do a clean install of 12.04.2 or 12.10.
With 10.04 you are out of support in a month anyway.