View Full Version : [ubuntu] Can upgrading solve hibernate issues?

March 28th, 2013, 02:05 PM
Some time back I had hibernation working (most of the time) properly on my 12.04.

Had to reinstall recently and now I am quite happy with my system. However, the hibernation does not work. The only notable difference from my former 12.04 install is that I have RAID-connected SSDs (had 2x128, now 1x256) and that I am using XFCE over Gnome.

Is it worth trying to upgrade to 12.10 or 13.04 in order to get hibernation to work? Could it be caused by RAIDing? I'd love to have hibernate working properly.

Currently I'm at a 64bit 12.04 on a Sony Vaio Z21V9E/B.

March 28th, 2013, 02:19 PM
Hello mreq,

I think if I remember right that 12.04 comes with hibernate not enabled. and here is a page telling how to re-enable it.

That being said - I believe you may have to also enable it in xfce by uninstalling xfce4 power manager and installing gnome power manager.
good luck

March 28th, 2013, 02:40 PM
Hi kc1di,

perhaps I wasn't clear in the original post.

I do have hibernation enabled, but after using
sudo pm-hibernate and turning the PC on again, I get the same result as with
sudo shutdown, ie the session or whatever we call it is not restored.

March 28th, 2013, 05:48 PM

March 28th, 2013, 09:48 PM
I have enough swap space. However, the UUIDs don't match. I'll try to update them and see how goes.

March 28th, 2013, 10:00 PM
Nope, didn't help :(

What's strange is that I get some strange messagess (but that happened on my farmer install as well).

option: option_instat_callback error -2

I asked, even started a bounty, but to no avail: http://askubuntu.com/questions/250673/hibernate-option-option-instat-callback-error-2

March 28th, 2013, 10:56 PM

March 28th, 2013, 11:13 PM
Yes it is. I only have 2x128 = 1x256 disc in my laptop. I'll try to play with a flash drive and gparted.

April 1st, 2013, 09:07 AM
The problem was in RAID partition /dev/mapper/someswappartition receiving dynamic UUIDs on boot.

Therefore the /etc/initramfs-tools/conf.d/resume was always outdated. I solved it by not using RAID (wanted a clean install of xubuntu anyway).