View Full Version : cant boot windows from grub

March 24th, 2013, 08:22 AM
hello, i have a acer s3-391 i installed 12.10 to dual boot by reading different threads.
when ubuntu boots i get grub which ubuntu boots fine. windows has two lines which i get a black screen with just some info saying error.
cant remember what exactly. my laptop is uefi with secure boot on both os boot fine. i just have to move the one i want up in the bio boot order.
i have tried boot repair a coulple time with no luck. here is the last time i used it. http://paste.ubuntu.com/5642374/

thanks in advanced for any help

March 24th, 2013, 12:36 PM
It might help to post the error you get when you try to boot in to windows.

March 24th, 2013, 03:54 PM
here is a picture of the grub screen
here is a picture of the error
both options for window give this error
gotta go to work. let me know if more info would help

March 24th, 2013, 06:17 PM
Based on your error, I found this thread:


Also, I'm not sure but this might help:


March 24th, 2013, 06:49 PM
I do not see anything wrong.
A bit unusual in that you have / in the SSD. Was this an UltraBook with Intel SRT? And is that turned off?

Some others
Acer Aspire S7 can't install ubuntu - UltraBook erased RAID meta-data
Acer V5-571P-6815 secure boot off worked Shows Diskpart

Some systems only boot with secure boot on. Some also have modified UEFI to only boot the Windows efi file.

Boot-Repair - Updated Jan 1, 2013 to not rename first time, but rename if first time Windows does not boot. Post 706 and 711
Boot-Repair copied /EFI/ubuntu/grubx64.efi to /EFI/Boot/bootx64.efi (in case the BIOS is hard-coded to boot into /EFI/Boot/bootx64.efi or secure boot signed GRUB file shimx64.efi.
I disabled secure boot, and unchecked it in boot-repair. It now bypasses Grub and goes straight in to Windows.
Renamed files:

To perform this, just run Boot-Repair --> Adv options --> tick "Backup and rename EFI files" --> Apply
Then reboot the PC to UEFI/BIOS and chose ubuntu, and please tell us what you observe.
Please enable SecureBoot in your BIOS, then run Boot-Repair --> Advanced Options --> "GRUB options" tab --> tick "SecureBoot" --> Apply.
To undo & to rename files to their original names, you just need to tick the "Restore EFI backups" option of Boot-Repair.

Intel Smart Response Technology
Some general info in post #3

March 24th, 2013, 08:54 PM
ok thank for all the replies. i got it to work.
i read the thread fred posted about boot repair.
first i disabled secure boot,then ran boot repair.
I then reset bios to default (had a couple of options that did nothing)
renabled secure boot. set ubuntu as 2nd in boot order after usb.
chose the fist option with windows in it got a recovery error .
then tried out the second option which booted to windows no problem.

again thanks for the help

this problem is solved:D