View Full Version : [ubuntu] Dual boot Windows 8/Ubuntu 12.10 won't load grub

March 8th, 2013, 01:06 AM
My wife has an HP Pavilion g6-2279wm. I created a partition to install Ubuntu 12.10. I turned off the secure boot, but it boots straight into Windows. I ran boot-repair from a live usb, and it gave me this url:


Any assistance would be much appreciated.

March 8th, 2013, 01:20 AM
- boot with Ubuntu (live version, from the USB key), and use GParted to change the flag of the EFI partition : remove the boot flag.
- shut down the PC, remove the USB key, and boot with windows 8 (the removal of the boot flag does not prevent windows to boot).
- within windows 8, call the partition tool (search for "partition" in the control panel or in the parameters setting search tool).
- in the partition tool, select the EFI partition, and give it a Drive letter (you can do it because it is not anymore marked as a "boot" partition).
- then open a File Navigator, and go to the Drive of the partition : you can see the EFI folder, and navigate down to the file : /EFI/ubuntu/grubx64.efi
- suppress the file.
- shut down the computer
- restart with Ubuntu (live version, from the USB key), and use GParted to change the flag of the EFI partition : set back the boot flag.
- install the Boot Repair tool (see here above, and the link to the Boot Repair page).
- proceed to the repair : choose your settings and option, etc...
- the process should be success-full, and the Ubuntu Grub panel appear when starting.

Taken from - http://ubuntuforums.org/showthread.php?t=2112273

March 8th, 2013, 01:48 AM
I attempted to do the above, but when I go to the drive, there is no ubuntu folder in the EFI folder. I am assuming that this is the main issue here.

March 8th, 2013, 02:04 AM
Some computers seem to have a write protected efi partition. Which as far as I know is not possible with FAT32. Several work arounds posted. Previous poster had one of them. There may be some sort of setting in UEFI, but no one has posted it. Sometimes setting that you do not think applies do apply. For example in BIOS system a user could not get it to work and he had floppy turned on in BIOS but had no floppy.

Best to fully back up efi partition before all the experiments.

grub-efi fails to install with Input/output error - locked efi
Some find chkdsk on efi partition helps, others backup, reformat and restore as current work arounds.
Another possible work around. HP Pavalion G7

March 24th, 2013, 10:59 PM
I tried reformatting the efi partition, and placing the files back in there. I then ran boot-repair, at which point it had me type commands into terminal to download signed efi files and install them. I got the following: paste.ubuntu.com/5644637. I rebooted, and still straight into Windows 8. Sorry about the delay in posts, but I have been very busy.

March 24th, 2013, 11:49 PM
With gparted you set the boot flag on the efi partition. It really is not the same with gpt partitions, as it really makes the partition the efi partition. All systems boot from the efi partition and you can only have one per drive.
Change sda2 to efi with boot flag in gparted.

Did you run the fixes suggested by Boot-Repair?

March 25th, 2013, 05:20 AM
did you do this in windows 8?:
open the control panel, choose system & security-->power options-->choose what the power buttons do-->change settings that are currently unavailable-->deselect "turn on fast startup".