View Full Version : [ubuntu] 12.10 & Windows 7 dual boot issue

March 3rd, 2013, 06:53 AM
I've just put together a new computer that I want to dual boot 12.10 and Windows 7. This machine has a Gigabyte 78LMT-S2P motherboard, AMD video onboard, AMD CPU. My HDD is 500GB, so I'm not lacking for space.
I am using Windows 7 professional 64 bit and Ubuntu 12.10 64 bit.
This is my first use of EFI, but I have installed many dual boot systems. I'd like to use EFI, if possible, because I see installing a >2TB drive in the future.
On this machine I have been able to install fully functional Windows 7 and 12.10 separately, but I cannot seem to be able to install a dual boot. Every time I install Windows, whether in EFI mode or not, the Ubuntu installer cannot recognize the existence of Windows. At the point in the installer where I have installation options, there is no option to install alongside Windows. Instead, I get the following:

This has been the case in every install attempt.
What I've done so far:
1. Install Windows without partitioning. Use full disk for Windows install, with the intent of shrinking the partition in order to install Ubuntu.
2. Use Windows diskpart to partition. Create one partition for Windows, leaving the remainder unallocated for use when installing Ubuntu.
3. Partition disk using gparted, creating an ntfs partition for Windows. (In this case, I was not able to install Windows either. The Windows installer wouldn't allow me to install to the partition)

1. Install Windows without partitioning, same a 1. above. I felt sure this would work, as this has always been my dual boot installation strategy. This time, however, it didn't work. I got the Ubuntu Installation Type window shown above. Additionally, gparted gives the message shown in the second image below, then shows the partitions as in the first image below. (It shows partitions the same, regardless of whether I select Yes or No) As you can see, gparted tells me that this is a gpt partition table, but Windows diskpart didn't show it as gpt. (In fact, installing Windows in MBR mode, it will not allow installation if the partition has the GPT tag) So, as far as Windows is concerned, this was not a GPT disk.

Can anyone provide any guidance? I've installed Windows 7 about 6 times so far and, if you've installed Window 7 pro, you know this is not a quick process. I'd be happy to have it done with.

March 3rd, 2013, 07:06 AM
Check this

March 3rd, 2013, 07:35 AM
Did you yet boot into your system UEFI BIOS to check the settings there which are related to your partition type and table issue ? There may be some critical setting that is not set correctly. Search your Gigabyte motherboard web site for your specific motherboard model to see if there are any know issues with possible updates to fix it.

March 3rd, 2013, 06:30 PM
Windows only installs in UEFI mode with gpt partitions. And with gpt partitions it will only work with UEFI. IF you really want MBR you have to totally remove gpt. Windows may install in BIOS mode but then only converts primary gpt partition table. But one of the advantages of gpt is that it has a backup partition table and Windows does not delete that. So Linux tools see the MBR partitioning and the backup gpt table and get confused and do not work.

You need both Windows & Ubuntu in UEFI or in BIOS mode. So if you want UEFI then you need gpt. Windows needs lots of extra partitions so best to let it install and then from Windows Disk tools shrink the Windows partition and reboot several times so it can run it chkdsk and make other repairs due to the resize.
Then you can boot Ubuntu in UEFI mode to install in UEFI mode.

You will need to use the 64 bit version of 12.10 or 12.04.2 and from the UEFI menu boot the flash drive in UEFI mode. That way it will install in UEFI mode.
Systems need quick boot or fast boot turned off in UEFI settings. Vital for some systems. Best to backup efi partition and Windows partition first.
Use Windows Disk Tools to shrink Windows main partition, but not to create any new partitions, if installing on same drive.
As of 12.04.2, it is possible to install on UEFI systems with Secure Boot enabled (using signed versions of Shim, GRUB, and the Linux kernel). This is only currently set up for Ubuntu (desktop, alternate, and server) and Edubuntu images due to pressures of time; we expect to enable it across the entire Ubuntu family for 12.04.3. Details:

March 4th, 2013, 12:27 AM
Thanks for all the replies. I solved it by the following (most of which is in the above posts, but apparently is the one thing I hadn't yet tried)
The key is to install Windows, allowing it to use the entire disk and then shrink the partition with Windows Disk Tools. Using Windows Disk Tools is the key that I had been missing.

March 4th, 2013, 12:35 AM
I would like to mark this thread as [SOLVED], but don't seem to have that option in Thread Tools, even though I'm logged in.