View Full Version : [ubuntu] Domain not working after upgrade from 12.04 to Ubuntu 12.10

February 26th, 2013, 11:16 PM
After attempting a failed upgrade from the command line I had to reinstall Ubuntu 12.10 completely with an iso image disc. Have not yet gone through the process of reinstalling from my back-up because if this problem is not resolved I am going back to Ubuntu 12.04.

Below is all the data I have entered using the Ubuntu Guide to reset my broomeunderground.com domain on my private server. Yet despite tests showing that things are working I get unable to connect to broomeunderground.com or using my IP address. Any ideas, guys, where I am going wrong? All suggestions would be greatly appreciated.

The four directories I edited with nano:
1. /etc/bind/named.conf.options
2. /etc/bind/db.broomeunderground.com (http://db.broomeunderground.com)
3. /etc/bind/db.192
4. /etc/bind/named.conf.local

And created the two DataBases
1. db.broomeunderground.com (http://db.broomeunderground.com)
2. db.192

1.) nano /etc/bind/named.conf.options

forwarders {;

2a) Create DataBase: sudo cp /etc/bind/db.local /etc/bind/db.broomeunderground.com (http://db.broomeunderground.com)
2b) nano /etc/bind/db.broomeunderground.com (http://db.broomeunderground.com)

; BIND data file for broomeunderground.com (http://broomeunderground.com)
$TTL 604800
@ IN SOA broomeunderground.com (http://broomeunderground.com). admin.broomeunderground.com (http://admin.broomeunderground.com). (
2013022201 (tel:2013022201) ; Serial
604800 ; Refresh
86400 ; Retry
2419200 ; Expire
604800) ; Negative Cache TTL
@ IN NS ns.broomeunderground.com (http://ns1.broomeunderground.com).
@ IN A
@ IN AAAA ::1
ns IN A

3a) Create DataBase: sudo cp /etc/bind/db.127 /etc/bind/db.192
3b) nano /etc/bind/db.192

; BIND reverse data file for com
$TTL 604800
@ IN SOA ns.broomeunderground.com (http://ns.broomeunderground.com). admin.broomeunderground.com (http://admin.broomeunderground.com). (
2013022201 (tel:2013022201) ; Serial
604800 ; Refresh
86400 ; Retry
2419200 ; Expire
604800 ) ; Negative Cache TTL
@ IN NS ns.
10 IN PTR ns.broomeunderground.com (http://ns.broomeunderground.com).

4. nano /etc/bind/named.conf.local

// Do any local configuration here

// Consider adding the 1918 zones here, if they are not used in your
// organization
include "/etc/bind/zones.rfc1918";

zone "broomeunderground.com (http://broomeunderground.com)" {
type master;
file "/etc/bind/db.broomeunderground.com (http://db.broomeunderground.com)";

zone "98.67.74.in-addr.arpa" {
type master;
file "/etc/bind/db.192";

However I do get this error when using restart for apache2 though using apache2 reload appears to be OK:

root@serv1ubuntu1210:/home/tom# sudo service apache2 restart
Syntax error on line 1 of /etc/apache2/sites-enabled/nano.save:
Invalid command 'VirtualHost', perhaps misspelled or defined by a module not included in the server configuration
Action 'configtest' failed.
The Apache error log may have more information.
root@serv1ubuntu1210:/home/tom# sudo service apache2 reload
* Reloading web server config [ OK ]

In file nano.save:

VirtualHost *:80>
ServerAdmin webmaster@localhost

Document Root /var/www/broomeunderground.com
ServerName broomeunderground.com


root@serv1ubuntu1210:/home/tom# dig -x

; <<>> DiG 9.8.1-P1 <<>> -x
;; global options: +cmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 60668
;; flags: qr rd ra; QUERY: 1, ANSWER: 1, AUTHORITY: 0, ADDITIONAL: 0


;; ANSWER SECTION: 43200 IN PTR cpe-74-67-98-211.stny.res.rr.com (http://cpe-74-67-98-211.stny.res.rr.com).

;; Query time: 27 msec
;; WHEN: Mon Feb 25 17:13:01 2013
;; MSG SIZE rcvd: 89


To test our example Forward zone file enter the following from a command prompt:

root@serv1ubuntu1210:/home/tom# named-checkzone broomeunderground.com (http://broomeunderground.com) /etc/bind/db.broomeunderground.com (http://db.broomeunderground.com)

zone broomeunderground.com/IN (http://broomeunderground.com/IN): loaded serial 2013022201 (tel:2013022201)

Similarly, to test the Reverse zone file enter the following:

root@serv1ubuntu1210:/home/tom# named-checkzone 98.67.74.in-addr.arpa /etc/bind/db.192
zone 98.67.74.in-addr.arpa/IN: loaded serial 2013022201 (tel:2013022201)

February 28th, 2013, 03:56 AM
:p FOR AN ASIDE: Originally I was very unhappy with how Ubuntu 12.10 was working with Gnome desktop. Pages were painfully slow at loading and the cursor was virtually impossible to use. I learned yesterday that this had a lot to do with 12.10 not supporting Unity 2D (http://www.omgubuntu.co.uk/2012/08/unity-2d-removed-from-ubuntu-12-10) and followed a suggestion to install and use LXDE (http://www.youtube.com/watch?v=M3HmcqQtjKg) desktop with 12.10. The difference in page loading speed and cursor use has been AMAZING!

Apparently Unity 2D was designed to work with older slower computer/servers while now there is Unity 3D which has something to do with LLVMpipe which IS installed on my server that has 4 processors and is only about 9 mos old. So I am more than a little surprised that my hardware wasn't able to handle the power use of Ubuntu 12.10 using Gnome desktop. Still working on this DNS problem but as soon as I get that resolved going to see if I can tweak 12.10 a bit to have 3D/LLVMpipe work and/or configured properly.