View Full Version : Ubuntu Boot Repair Doesn't Appear Event After Boot Repair

February 22nd, 2013, 07:56 AM

I had Windows 7 already installed. I then installed Ubuntu 12.10 64 bit version. However Ubuntu boot menu didn't appear and I then used Boot Repair (via Ubuntu Secure Remix: http://sourceforge.net/p/ubuntu-secured/home/Home/).

Following was the repair note for the first time.

Though the Repair software said it was successful, no menu appeared and Windows loaded directly at reboot.

I then tried the Repair for the second time. Following was the note.

Still no luck.

In both cases, I tried Recommended repair. Should I try advance options? If so what to try (Restore MBR?)?

I couldn't find a detailed guide. Following was the best I could find and it had only screen shots of advance options.

FYI: Both Ubuntu installation and Repair were carried out with a USB stick.

Any help is much appreciated.

Thanks in advance...

February 22nd, 2013, 10:00 AM
is the ubuntu partition set with the "boot" flag ?
is grub installed on /dev/sda ?

boot on a livecd to start gparted, and set the boot flag

sudo grub-install /dev/sda
sudo update-grub

February 22nd, 2013, 09:26 PM
Actually boot flag should only be on Windows boot partition usually sda1. Otherwise Windows will not boot with Windows boot loader.

And grub does not use boot flag, but a few BIOS need to see a boot flag on a primary partition (assumes Windows?).

Try dino99's suggestion on reinstalling grub to MBR of sda.

Links to pastebin are not working. But I tried one I had and it is not working either, so it looks like pastebin error.

February 24th, 2013, 09:00 AM
Hi dino99 and oldfred,

Thanks for the info and sorry about the delayed reply.


I think the grub is installed in /dev/sda since it's the default option mentioned in Ubuntu installer (I didn't change it). I am not sure about the boot flag. I will check that and let you know.


Following is how partitions were.

/dev/sda1 ntfs 104MB
/dev/sda2 ntfs 328512MB
/dev/sda3 ntfs 483183MB
/dev/sda5 ext4 / 40959MB
/dev/sda6 ext4 /var 30719MB
/dev/sda7 ext4 /home 89999MB
/dev/sda8 swap 6318MB

I guess /dev/sda1 is the MBR. I will try dino99's instructions. If it didn't work, I will try to re-install Ubuntu.

When re installing, shall I choose /dev/sda1 one for installing the Grub? Will that erase Windows boot loader?

There is an option called "Restore MBR" in Boot Repair. If I try that, will it erase Windows boot loader?

My problem is, if Windows boot loader is erased, there won't be an option to access Windows.

Thank you

February 24th, 2013, 04:05 PM
NEVER install grub to a NTFS partition like sda1. Windows has vital boot info in the PBR partition boot sector which is just the first sector of a partition and used only for windows boot code in NTFS.

The MBR is just the first sector of the hard drive and is not part of any partition. So you install grub to sda or the MBR of the drive.

If you want a gui to fix things, you can download this into your liveCD.

Post the link to the BootInfo report that this creates. Is part of Boot-Repair:
Boot Repair -Also handles LVM, GPT, separate /boot and UEFI dual boot.:
You can repair many boot issues with this or 'Create BootInfo' report (Other Options) & post the link it creates, so we can see your exact configuration and diagnose advanced problems.
Install in Ubuntu liveCD or USB or Full RepairCD with Boot-Repair (for newer computers)

February 25th, 2013, 03:22 AM
Hi oldfred,

I followed the instructions. Following is the boot info output. I have also attached a doc file.


February 25th, 2013, 04:13 AM
GRUB is not installed in the MBR of sda, Windows is. Boot the Ubuntu Live CD/USB, try ubuntu without installing. When desktop loads open terminal and run
sudo mount /dev/sda5 /mnt

next run this in terminal
sudo grub-install --root-directory=/mnt/ /dev/sda

Reboot and you should be good to go.

February 25th, 2013, 05:50 AM
Hi presence1960,

Thanks a lot for the help!

I tried your instructions and now the dual booting works.

I got following output (error) when I run "sudo grub-install --root-directory=/mnt/ /dev/sda"

/usr/sbin/grub-bios-setup: warning: this LDM has no Embedding Partition; embedding won't be possible.
/usr/sbin/grub-bios-setup: warning: Embedding is not possible. GRUB can only be installed in this setup by using blocklists. However, blocklists are UNRELIABLE and their use is discouraged..
/usr/sbin/grub-bios-setup: error: will not proceed with blocklists.

Despite the error it worked. I had a Windows boot menu created with EasyBCD. So that menu loads first and there I have to choose Ubuntu. I have no problem with that :-). I actually set Ubuntu as the first choice so it automatically loads.

Thanks all for spending the time on the issue. I had wasted lot of time on dual booting and didn't want to give up. ):P

February 25th, 2013, 05:53 AM
Glad it worked! Enjoy. Was not aware you used Easy BCD. I don't think you mentioned that.

February 25th, 2013, 05:56 AM
Sorry I couldn't mention about EasyBCD. Since I was having issues with the Ubuntu boot loader, I also tried Windows way.

February 25th, 2013, 03:26 PM
The LDM error is a bug with the new grub2 2.00. It now seems to recognize dynamic Windows partitions, but Linux still does not work with them.

So if you have or had dynamic partitions meta data is left on the hard drive and grub sees that.

ldm bug grub2 2.00