View Full Version : [ubuntu] Ubuntu on Asus Vivobook S200E

February 17th, 2013, 02:07 PM
I got a Asus Vivobook S200E, which came with Windows 8 preinstalled. I booted Arch Linux from a USB stick and deleted all the partitions and installed Arch, but then couldn't get it to boot off the hard disk. I think this is because of EFI.

I read some success stories with Ubuntu, so I created a 64 bit 12.10 USB, but this also doesn't work. I get the GRUB screen offering to try Ubuntu without installing or to install Ubuntu. If I pick either, I just get a blank screen. There is some activity on the USB stick, but then nothing. If I hit enter, there is some more activity, and then nothing. Ctrl+Alt+Del will often reboot the computer.

I've tried modifying the boot parameters, e.g. gfxpayload=text, removing quiet and splash, adding nomodeset. But with no success.

Is this another symptom of a EFI problem, or something else? I hope someone can help. Thanks.

February 19th, 2013, 09:36 AM
I believe you'll need to go into the UEFI config utility, by pressing some key or key combination as the device powers on, and find something like "enable legacy boot" and turn it on. You should be able to google the exact steps.

February 20th, 2013, 10:40 AM
Yes, I had enabled CSM - Compatibility Support Module - but on its own, that didn't work. What finally did the trick was changing the disk from GPT to MBR. Now I can boot off the disk in non-EFI mode.

February 20th, 2013, 09:23 PM
Hello Smithuncrowe

I am having similar problems.
One question.

What do you mean by " changing the disk from GPT to MBR" ??

I looked up http://en.wikipedia.org/wiki/GUID Partition Table
and see what is is - but how did you do the change?

For grins, this is what I tried...

If I may - a second question?
How do you get to "boot repair"?
T H A N K Y O U,

February 20th, 2013, 09:34 PM
See your thread.

Often whether UEFI or BIOS you may have video issues. Particularly with nVidia or AMD. And some of the very new systems need other boot parameters to work around some new hardware.

How to set NOMODESET and other kernel boot options in grub2 - both liveCD & first boot, but different

February 21st, 2013, 12:59 AM
I hadn't come across GPT disks before. There was a 1007K empty partition at the beginning of the disk. I think one is supposed to install the boot loader in that, but I couldn't figure out how to do it. With a combination of gdisk, cfdisk and gparted, I got rid of the empty partition, and was able to install the bootloader in the MBR. Sorry I can't be more specific. But now I can boot with the old BIOS (CSM) and GRUB.

February 21st, 2013, 01:09 AM
But your Windows 8 uses gpt and UEFI, so it will not work now.

Generally best not to convert to MBR. Windows only boots from gpt with UEFI and UEFI has to have gpt.

But Ubuntu will boot from BIOS or BIOS mode with either gpt or MBR.

Windows has specific partition requirements for Windows with UEFI.
Microsoft suggested partitions including reserved partition for gpt & UEFI:
Older Windows info on gpt - 2008 updated 2011
Windows technical info on gpt and GUIDs
Order on drive is important:

February 21st, 2013, 07:31 AM
I'd already removed Windows8. If I'd wanted to keep it, I might have been more careful. But I didn't have anything to lose.