View Full Version : [ubuntu] Alt-Tab not working after upgrade to QQ / 12.10

February 15th, 2013, 03:24 PM
Hi there,

I recently upgraded from PP to QQ which broke the ability to switch between running applications by pressing Alt+Tab which is such a showstopper I never believed could ever be.

The affected host is a ThinkPad X61s. I'm not quite sure if this is of any relevance but I think Unity/Compiz is running on LLVM - not even sure if this statement makes any sense at all.

So until now I tried several countermeasures in any combination imaginable to tame that beasty behaviour - running out of ideas as of now after having tried every hint I could find:

bound and unbound and rebound the settings/keyboard/shortcuts/navigation/Switch applications over and over again
massive amount of reboots
activated, deactivated, reactivated switchers and set, unset, reset plugins and their key bindings - even other ones as Alt+Tab - in ccsm under

Unity Plugin
Window Mgmt - Application switcher and Static application switcher

deactivated Alt as a hotkey for the HUD
even switching keyboard layouts

All to no avail which led me here: any ideas, any Ubuntu one?

It may be worth mentioning that the Alt keys themselves are working as shown by xev. I can access the menu, too. What makes me wonder is the fact that I can get the HUD by tapping Alt_R but not by using Alt_L (so I tried removing the HUD key binding which as stated didn't work). App switching itself is not possible using either Alt key.

This highly unwanted behaviour is the same using the internal keyboard as well as my bluetooth one.