View Full Version : [ubuntu] Windows 8 not loading after Ubuntu 12.10 installation - UEFI

February 13th, 2013, 11:57 PM
I bought a new laptop with Windows 8 preinstalled and, as I always do, want to install ubuntu and make the dual-boot.

So I searched on google how to do it, since it has the new UEFI stuff and so on. After a lot of searching, I choose this tutorial (https://help.ubuntu.com/community/UEFI) to follow.

After the installation, the GRUB menu didn't appeared. It booted straight to ubuntu. So I runned the boot-repair application. In the next restart, the GRUB menu appeared and has a windows 8 option, but it didn't worked. I executed the boot-repair a second time (as saying in the tutorial) but the problem is still the same: windows 8 don't boot. It says that can't locate the efi file or something like that.

So I am here to indicate the URL generated by boot-repair (in the second run).

Anyone can help me?

Thanks in advance.

February 14th, 2013, 12:08 AM
Is Ubuntu booting ok?

And what computer is it. It has a label of Packard Bell. Your UEFI looks similar to some Lenovo systems, but there are only a few UEFI vendors.

Are you booting Windows with the new entries from Boot-Repair not os-prober?

grub2's os-prober creates wrong style (BIOS) chain boot entry
type of entry from Boot-Repair that should work.
'Windows UEFI loader'
Type of entry that does not work:
'Windows ...) (on /dev/sdXY)'
Boot Repair -Also handles LVM, GPT, separate /boot and UEFI dual boot.:

February 14th, 2013, 05:46 PM
Thanks for the fast answer.

Yes, my ubuntu is booting perfectly.

My computer is a Packard Bell EasyNote LE11BZ.

Yes, I am trying to boot Windows with the entries of boot-repair. There are two options in my grub.conf:

### BEGIN /etc/grub.d/25_custom ###

menuentry "Windows UEFI loader" {
search --fs-uuid --no-floppy --set=root 786A-CE61
chainloader (${root})/EFI/Microsoft/Boot/bootmgfw.efi.bkp

menuentry "Windows Boot UEFI bootx64.efi.bkp" {
search --fs-uuid --no-floppy --set=root 786A-CE61
chainloader (${root})/EFI/Boot/bootx64.efi.bkp
### END /etc/grub.d/25_custom ###

None of the two works.

I have checked if the efi.bkp files are located in the directory. That's all okay.

February 14th, 2013, 05:53 PM
Did you use Windows disk tools to shrink the Windows partition? It has to run chkdsk after a resize and it is best to do that from Windows and reboot several times so it can run its fixes.

If you resized during the install Windows may need the chkdsk or other repairs.

The UEFI entries look correct and then it is probably some internal Windows issue.

If you know someone with Windows 8.
Windows 8 UEFI repair USB must be FAT32

I do not know if with Windows 8 it still is f8 to get to repair console. Some booting from grub with Windows 7 found pressing f8 almost at the same time as clicking on the Windows entry in grub menu would get them into the Windows repair console. Some said they had to try several times as it is real quick.

Does UEFI menu have an entry for Windows repairs/recovery, not vendor recovery as that may just restore system to as purchased.

February 14th, 2013, 06:04 PM
Yes, I did the shrink in the Windows. I will try to run the chkdsk.

But this is the second time that I installed ubuntu. The first time, the same problem occurs, then I went to the boot-repair and selected the option "Repair file system", unchecked the "Secure Boot" option and rebooted the system. After the reboot, the windows booted okay but not the ubuntu. Weird?

I will try to do the same thing now to execute chkdsk and see what happens.

Other thing: I don't know hwow to make GRUB appear again after this operation. In the first time, I booted with my liveUSB and executed boot-repair but didn't worked. I had to install ubuntu again.

February 14th, 2013, 06:58 PM
You have to directly go into UEFI menu and choose ubuntu. If you go into it from Windows, then windows remains the default.

Boot-Repair also renames files if you run it more than once. Some systems only will boot the Windows efi file. So Boot-Repair will rename the shim file to the Windows name so you can boot Ubuntu and then grub is set to chain load to the backup of the Windows efi file.

How Boot-Repair works with UEFI systems - post 687 Dec 15, 2012
How Boot-Repair fixes a Ubuntu with grub-pc with efi Windows
Boot-Repair - Updated Jan 1, 2013 to not rename first time, but rename if first time Windows does not boot. Post 706 and 711
Boot-Repair copied /EFI/ubuntu/grubx64.efi to /EFI/Boot/bootx64.efi (in case the BIOS is hard-coded to boot into /EFI/Boot/bootx64.efi or secure boot
signed GRUB file shimx64.efi.

February 14th, 2013, 07:35 PM
Okay, I did the boot-repair "repair file system" and booted in windows. In that case, the GRUB menu does not even appear. It boots directly to windows.

I executed chkdsk as administrator. Runned fine, no errors. After, I reseted the machine several times.

I entered in the BIOS (setup utility), the boot mode UEFI is setted. There isn't a ubuntu/linux option, just the normal ones (USB, CDROM) and Windows boot manager.

So, I booted into ubuntu trhough the live USB. Executed again the boot-repair app, and I have the same problem. Nothing changed. It has generated a new pastebin file. I don't know if it change aomething, but here it is: http://paste.ubuntu.com/1652800/

I am trying some other tutorials either, but no one is working.

February 14th, 2013, 08:25 PM
With your UEFI, BootInfo shows boot options. And it shows two different ones which I am not sure how they are shown in your UEFI menu.

reinstall the grub-efi-amd64-signed shim-signed linux-signed-generic of sda7
Installation finished. No error reported.
grub-install --efi-directory=/boot/efi --target=x86_64-efi --uefi-secure-boot : BootCurrent: 0001
Timeout: 2 seconds
BootOrder: 0001,0000,0005,0004,0002
Boot0000* HDD0:
Boot0001* USB HDD: KingstonDataTraveler G3
Boot0002* Windows Boot Manager
Boot0004* HDD0:
Boot0005* HDD0:
BootCurrent: 0001
Timeout: 2 seconds
BootOrder: 0003,0001,0000,0005,0004,0002
Boot0000* HDD0:
Boot0001* USB HDD: KingstonDataTraveler G3
Boot0002* Windows Boot Manager
Boot0004* HDD0:
Boot0005* HDD0:
Boot0003* ubuntuThe first says your flash drive is first boot, the second says ubuntu is first to boot. Where in UEFI menu do you see these choices? Or perhaps one is previous and the other current?

February 14th, 2013, 08:44 PM
I just saw my UEFI boot menu by reseting the computer and hitting F10.

There are the ubuntu and windows option, actually. But when I select windows, it gives me an error and don't boot.
When I select ubuntu, the GRUB menu appears with two options of windows and one for ubuntu. Windows not work at all, just ubuntu.

I don't know why my flash drive is there... I think that is because I did the boot-repair by live USB... I don't know, but there is no option like that in the UEFI boot menu neither in GRUB menu.

I am still with a no bootable windows and a perfectly bootable and fully functional ubuntu.

February 15th, 2013, 12:44 AM
Boot repair may have you in the mode where it uses the shim file as the Windows file. But then I would think booting Windows would just give you grub.

You said 5 hours ago that Windows booted.

It looks like Boot-Repair made these changes.

Add .bkp to /mnt/boot-sav/sda7/boot/efi/EFI/Microsoft/Boot/bootmgfw.efi
cp /mnt/boot-sav/sda7/boot/efi/EFI/ubuntu/shimx64.efi /mnt/boot-sav/sda7/boot/efi/EFI/Microsoft/Boot/bootmgfw.efi
cp /mnt/boot-sav/sda7/boot/efi/EFI/ubuntu/shimx64.efi /mnt/boot-sav/sda7/boot/efi/EFI/Microsoft/Boot/bootx64.efi (& .grb)
Add .bkp to /mnt/boot-sav/sda7/boot/efi/EFI/Boot/bootx64.efi
cp /mnt/boot-sav/sda7/boot/efi/EFI/ubuntu/shimx64.efi /mnt/boot-sav/sda7/boot/efi/EFI/Boot/bootx64.efi
Add /mnt/boot-sav/sda7/boot/efi Microsoft efi entries in /mnt/boot-sav/sda7/etc/grub.d/25_custom
Adding custom /mnt/boot-sav/sda7/boot/efi/EFI/Microsoft/Boot/bootmgfw.efi
Add /mnt/boot-sav/sda7/boot/efi Boot efi entries in /mnt/boot-sav/sda7/etc/grub.d/25_custom
Adding custom /mnt/boot-sav/sda7/boot/efi/EFI/Boot/bootx64.efi

So the only way to get to the correct Windows boot file is the grub menu. And then booting the backup of bootmgfw.efi should work.