PDA

View Full Version : [ubuntu] Software updater will not work



Chris62
January 29th, 2013, 10:54 AM
Hi,

I have a desktop and a laptop, both dual boot Windows 7 and Ubuntu 12.10. The Ubuntu installation on both machines is identical in that Software Updater has been run at the same time on both machines. The last time that I ran it, there was an update of the kernel which resulted in the desktop having 3.5.0-22-generic but the laptop still has 3.5.0-18-generic.How can I update the laptop kernel, or should I not bother? I tried doing it with Synaptic but the laptop would not boot properly afterwards so I have removed the one that I installed using Synaptic.

ibjsb4
January 29th, 2013, 11:35 AM
If its not broke, don't fix it :)

Or you can do a dist-upgrade to a new kernel.


sudo apt-get update && sudo apt-get dist-upgrade

Number three

https://help.ubuntu.com/community/AptGet/Howto#Maintenance_commands

Chris62
January 29th, 2013, 01:25 PM
Many thanks for that. It didn't change anything but as it isn't broke, I won't try fixing it anymore

raja.genupula
January 29th, 2013, 02:55 PM
If you broke anything


sudo apt-get install -f will help to fix.

to get complete updates

sudo apt-get update
sudo apt-get upgrade
sudo apt-get dist-upgradehope that helps.

else you can use update-manager also.

always the server does the matter.

Chris62
January 30th, 2013, 05:33 PM
Hi raja.genupula,

Thanks for your message. Although I had intended to leave the system as it is, I tried your suggestions but the kernel was not upgraded. It did, however, find an earlier kernel which has now been removed.

I am still at a loss to know why my desktop has kernel 3.5.0-22-generic and the laptop has 3.5.0-18-generic. The only difference between the two is that in the desktop, Ubuntu has a hard disc to itself and in the laptop Ubuntu and Windows 7 share the same hard disc; the two computers have different processors