View Full Version : [ubuntu] Nvidia 610m Optimus Hybrid--no desktop after installation?

January 27th, 2013, 08:45 PM
My Acer Revo 36xx just died (RIP) so I needed a new htpc. I picked up an Asus eb1033 without realizing the problems I would have with an Optimus card.

The basic problem is this: I can install Ubuntu 12.04 or 12.10 (both x64 of course) but then I can never get past the login screen to any desktop. The screen flashes colors and then it sends me back to the login screen. Obviously complicating all of this is the fact that I'm using HDMI out to drive my television.

I will say, however, that 12.10 livecd session will give me a desktop, albeit a sluggish one.

I've tried just about every workaround (updated kernel, updated nvidia drivers, bumblebee, various tweaks, etc) posted in the last couple days but Im stumped.

Do you all have any ideas or am I going to have to spring for a copy of Win7 to get this nettop working with hdmi?

January 28th, 2013, 01:33 AM
Win 7 it is I guess.

Yellow Pasque
January 28th, 2013, 01:42 AM
Win 7 it is I guess.
This is what happens when you don't do your homework, kids!

January 28th, 2013, 01:48 AM
I'll have to admit that it was something of an impulse buy. The problem is that I really didnt want to buy AMD (my e350 is good enough to work on but not so hot for video playback) and I didn't want to go with an Intel 4000 chip, although perhaps that would have been the smarter choice.

The only thing I can find that would remotely work is this:


Not really what I need in my living room, unless I could log in through, say, a vga connector and then flip back to HDMI.

I trust my chip will be supported eventually, but in the meantime I need to get up and running with something.

June 22nd, 2013, 03:08 AM
I made the same "mistake" - went and bought the EeeBox EB1033 thinking that some people had Linux up and running on it and that I should be right... NOPE!

I've got Ubuntu 13.04 installed and for the most part it's working - big big problem however is that I can't get the NVidia drivers installed and thus can't use it for XBMC with VDPAU decoding. :( I've tried PPAs (XOrg-edgers) and Bumblebee, nope... can't get it to work.

I am thinking of running Win7 for a few months until the situation is "resolved"... but who knows how long it will be until then :(