View Full Version : [ubuntu] Windows 8 UEFI dual boot problem with Ubuntu 12.10

January 24th, 2013, 11:24 PM
I have installed Ubuntu 12.10 on my computer that had Windows 8 pre-installed. I used the instructions on this page:


After following the instructions through to the end, and having run Boot Repair twice, I am still unable to load Windows 8 from Grub. I am, however, able to load it from BIOS.

Here is the boot info: http://paste.ubuntu.com/1567295/

Any suggestions to fix this would be greatly appreciated. While loading Windows from the BIOS is workable, it is certainly not ideal.

Thanks in advance.

January 25th, 2013, 12:05 AM
You have 5 Windows entries in grub. The first 4 all say recovery, but the first 2 are from your efi partition and should boot Windows. The next two are from recovery partition and the last one is the bug in grub2 where it creates a BIOS type entry.

You also have the new boot into UEFI as the last entry. Does that work?

So when you boot from UEFI/BIOS and choose ubuntu, from grub menu do not the first 2 Windows entries work?

January 25th, 2013, 12:35 AM
Nope, none of them work. I tried them all before posting. The last one says something to the affect of "invalid EFI file path" and the rest say something like "could not load image."

January 25th, 2013, 12:45 AM
They look correct and generally boot repair does put in the correct entries. Do you have secure boot on or off?

Since it seems to be the path, we can try changing the search by UUID (which is the preferred way) to hard coded.

At the grub menu press e on the first Windows entry. make sure it the one with the UUID E060-6E5F and change the entire search line to this:
set root='hd0,gpt2'

See if you still get same error or not.

January 26th, 2013, 02:32 AM
Secure boot was on. I decided to try with it off before editing anything and it worked great!