View Full Version : [ubuntu] 12.04 with nvidia GPU

January 22nd, 2013, 11:34 PM
I have tried to search for any answers for Ubuntu 12.04 running an nVidia GeForce 7300. I am not getting the resolution I know my Asus monitor is capable of. Ubuntu 11.10 runs the repsitories' nvidia driver.

With Ubuntu 12.04 I do not have a usuable Gnome desktop with a restart menu off the screen. Unity2D is big and ugly. Anyone on the forums claiming sucess has a specific formula for generating headers that interface their hardware.

What works?? I've downloaded nvidia-current from repositories, no joy.
sudo apt-get purge nividia*
I downloaded from the nvidia downloads 'installer 304.64'. The installer halts and notifies me I should stop x-server. I stopped right there and posted my thread on the forums.

January 23rd, 2013, 01:22 PM
No help? Is Ubuntu 11.10 the last generic distro? Have we gone like Microsoft with a supported hardware list? I would be willing to live with Unity2D over a desktop, but the Unity GUI is not high-res.

If nVidia won't work with Ubuntu then somebody please recommend a GPU card that will. Ubuntu 12.04 thinks I am trying to set the resolution of a Laptop. The nVidia driver thinks my x-server is non-compatiable.

Or, would RedHat, or any other Linux, be compatiable with nVidia OEM graphic add-on cards?

January 23rd, 2013, 01:29 PM
I downloaded from the nvidia downloads 'installer 304.64'. The installer halts and notifies me I should stop x-server.

You need to stop the x-server to install the nvidia driver that way. After you login press CTRL+ALT+F1 and login again. Then type

sudo service lightdm stop
to stop the x-server and install the nvidia drivers

January 23rd, 2013, 02:06 PM
"I've downloaded nvidia-current from repositories, no joy."

How did you download them, and coukld you expand the "no joy" a bit? Were you not able to install the driver, or didn't they appear in the installed drivers list? Or did they not activate? Or they did, but that didn't solve your resolution problem? Did you get nVidia's settings tool or not? Did it work?

In general, nVidia cards are definitely supported and work well with Ubuntu. There sure aren't any plans on limiting support for any hardware that can be supported (within limits of what's reasonable, of course). And when it comes to proprietary drivers like the nVidia one, it really is up to the manufacturer do decide what they support, being a closed-source driver Ubuntu's developers wouldn't be able to decide what they support or don't even if they wanted to...

January 23rd, 2013, 11:06 PM
Thanks for the reply, both of you.

I never had an issue with nVidia and Ubuntu since the 5.10 version. I always clicked the 3rd-Party Drivers available icon after the first reboot, but it didn't work for me this time with 12.04. The driver installs nVidia settings but leaves out the selectable Resolutions sizes. There used to be an 'Auto' and that gives the optimal 1920x1280 desktop, centered on the monitor.

Right now, I have the Shutdown icon off the right-hand side of the monitor and have to use Terminal sudo reboot or the shutdown.

Trying several suggestions I have apt-get purged nvidia*, and tried logging in as root in Terminal mode to use NVIDIA-Linux-x86_64-304.64.run. That crashes every time it tries to install. I have installed the list of jockey-gtk, nvidiacurrent, etc. Nothing has worked with Linux.kernal.32.

Unless there is any other thing I should try, I'm going to reformat the partition and re-install Ubuntu 11.10 and let that upgrade back up to linux.kernal.30. At that point I MAY, may decide to use the LiveCD to upgrade instead of install 12.05.