View Full Version : 12.10/win 8 black screen after system update

January 22nd, 2013, 02:56 PM
A few days ago I did a routine system update and now on reboot I get a back screen. I have a ubuntu 12.10 Win 8 dual boot system that was running fine. AMD card.

I would get grub then choose the normal ubuntu boot and then the purple screen, I would see the Ubuntu screen with the 4 dots, then black.... well an off color black/grey. I would see the cursor arrow way way at the top, only part of it. The screen would flicker in the bottom right corner.

I restarted... when the grub loaded I chose "e" and changed the quiet splash to nomodeset then hit f10.

It then loaded and I get as expected bad graphic display....

What are my options now... it's been a while since I've had to mess with the nomodeset issues. I wonder if there is an issue with a driver or kernal. I did have to restart after this update. I have seen some others with the same issue.



January 22nd, 2013, 04:39 PM
Updates will require a re-start if a new Linux kernel had been brought in. There are other reasons for a re-start being required to bring the updated software in use.

You can try opening the Advanced Options sub-menu and choosing an earlier kernel.

How bad is the graphics once you get to a desktop with nomodeset? Using that option runs the OS, loading it without setting a video mode. Have you tried logging out and then back in?

You can try changing the video driver to an alternative one. Look for the Additional Drivers tab in System Settings>Software Sources.

Proprietary drivers have not been doing too well lately, in my opinion.


January 22nd, 2013, 09:29 PM
Its usable.... but not as good or at least acceptable.

I guess I will have to look at the drivers. I really don't want to mess with drivers, since the way it was was in fact FINE.

I used to never install all those updates because you never know what your getting. I think from now on I will not install all those pesky updates....

I can roll back to an earlier kernel..... I feel there must be a bug with this one it should be reported as such... if in fact it was a kernel etc...


January 23rd, 2013, 07:17 PM
So, I used the driver.....

Using Video driver for the AMD graphics accelerators from fglrx (proprietary)

All seems to be well at this time.

Not sure what the issue was but it works, so I'll mark this as solved.