PDA

View Full Version : [xubuntu] 12.10 update, screen black



PerLowgren
January 18th, 2013, 06:21 PM
Everything has been working exceptionally well with 12.10 until today. The latest update installed and I rebooted and everything went black. It might be the driver for Nvidia, but I have no clue as to what the problem is.

My computer is an Asus Eee 1215N.

After the screen went black, I've reinstalled Xubuntu, well this is the third time so far, and everything works up until I make the dreaded sudo apt-get upgrade and reboot. The blue Xubuntu flash screen comes up before it turns black, and I can Ctrl-Alt-F1 to enter the terminal but I don't know what to do then. Since a fresh install of Xubuntu works I can simply avoid the upgrades, but I think it would be better to find a solution. Should I report this bug somewhere, I'm not sure where to turn?

nykobing
January 18th, 2013, 06:28 PM
I am getting the same thing in regular gnome 12.10, I don't have a nvidida card. I had to choose an older kernal in advanced start up items.

PerLowgren
January 19th, 2013, 05:49 AM
After a clean installation, there are 130+ updates, and one of those (or perhaps a combination of them) cause the problem. It could be the kernel, some of the updates are Linux kernel images. There are also GTK+ updates and Xorg updates that could be the problem as well, difficult to say.

Salahare
January 19th, 2013, 09:46 AM
I have the same issue after updating straight from 12.04, and my monitor tells me my resolution is set to higher than what my monitor can probably handle... so I assume that everything is working fine excepting the resolution.
Other than that the startup is fine, I even see the GRUB before boot...
Oh!
When I enter recovery mode and choose any option other than "resume boot" it tells me that:


/dev/sdb1: Superblock last mount time is in the future.

(by less than a day, probably due to the hardware clock being incorrectly set) FIXED
/dev/sdb1: clean, 398504/14745600 files, 12270376/58960640 blocks

Could the issues PerLowgren and I have be similar enough?
My computer is self-built, with an ASUS P8Z 68-V LX motherboard and a Radeon 6600 HD.

PerLowgren
January 19th, 2013, 08:27 PM
This seems likely, that we are experiencing the same thing Salahare.

I've reinstalled Xubuntu three times, and after the first installation the there was a very strange resolution desktop. My mouse wasn't working but my keyboard was. I rebooted and got the same result. Second installation it went black again. Booting works fine, everything works up until after the flash-screen, then nothing visible, but the OS seems to be running, and I can Alt-Ctrl-F1 to get to a terminal.

Salahare
January 21st, 2013, 07:10 AM
I forgot there was a hotkey for the Terminal. Man do I feel noobish.

So the first thing I tried after entering the Terminal was to run 'sudo apt-get update' again, and it told me my dkpg was corrupted and I had to configure it.

after a couple tries going 'sudo dkpg --configure -a' I still couldn't run apt-get because so many sectors have errors, but a restart revealed my desktop in GUI form right as rain... but I still have Package manager issues I'll have to address either on my own or in a new thread.

This solution might not work for you as you had wiped and reinstalled your OS and are not working with files carried over from your previous version... but I thought I'd share what worked for me. u_u;

I hope your solution comes swiftly!