PDA

View Full Version : [SOLVED] no internet connection in ubuntu but in windows7



msinfo
January 13th, 2013, 09:46 AM
hi experts,
i have dual boot system with Win7 and Ubuntu 11.04.
before problem internet was working fine on both OS.
two days ago, som cable problem occured, which cable guy troubleshooted by replacing faulty RJ45 connector.
from that point internet is working fine on Win7 but not on Ubuntu.
i have checked IPV4 settings of Ip, DNS, Net mask, they are same on both side.
when i ping default gateway from Win7 it gives response, but from Ubuntu it fails.

what i tried :
disconnected cable for while.
deleted connection and remade connection on ubuntu

regards : msinfo

catalin.vasilescu
January 13th, 2013, 10:58 AM
can you try to use 10mb full duplex in ubuntu and see if the prob is same?

msinfo
January 13th, 2013, 12:38 PM
hi, catalin.vasilescu
thanks, for answer. could you further elaborate that. . .
means how i do that. In win7 i could see this settings in nic configuration pop up box.
how do i change this settings in ubuntu (via commandline, / or gui way)

update : i can see pop up notification saying my wired connection connected
but nothing works actually.
i failed pinging my gatway and dns servers, but same works fine in win7
regards : msinfo

catalin.vasilescu
January 13th, 2013, 02:08 PM
You need ethtool.
In terminal (suppose you use eth0):

apt-get install ethtool net-tools

To see actual configuration of eth0 :
ethtool eth0

To change the speed-duplex in 10FD run the command :

ethtool -s eth0 speed 10 duplex full

And check again the config of eth0

ethtool eth0

msinfo
January 13th, 2013, 02:46 PM
hi,
thanks for necessary info. . .
since my Ubuntu is offline i can't install via online way.
i have downloaded 4 files of version 3.7 from,
http://www.kernel.org/pub/software/network/ethtool/

how do i install them. . .

regards : msinfo

msinfo
April 22nd, 2013, 12:47 PM
Hi,
Thanks to those, who tried answering.
Don't know how, but when today, I boot machine in Ubuntu OS, I could use, my Internet connection perfectly.
This is second time, when a Ubuntu problem, has been solved automatically, without any change in settings, or software.
Note: I was trying to install ethtool, to diagnose my internet connection problem, but now, it has been auto solved. Don't know how?