View Full Version : [ubuntu_studio] 12.xx Installer does not load while trying to create a Win8 Dual Boot with EFI

January 3rd, 2013, 05:29 PM
My business partner purchased an hp Pavillion P7-1417 (without talking to me first, I would have never purchased an hp..). I want to dual boot the pre-installed Windows 8 with Ubuntu Studio.

First, I tried 12.04 because I wanted the LTS version, but could not get the installer to load unless it was in Legacy mode. I read on a forum, 12.10 was signed as EFI, so tried that, with similar results/

When I boot the installer disc, I get the grub menu. No matter what option I select, the grub menu disappears and I get a blank screen.

At one time, I ran the installer in legacy and created a new installation that wiped the HDD, so I know it's not a graphics issue.

I have tried just about EVERY option in the BIOS, but cannot get the installer to load now.

If I install 12.04 with Secure Boot enabled, and custom keys (HP keys do not recognize Ubunutu), I get an
Empty Security Header error. If I try the 12.10 disc with the same configuration, I get a blank screen and nothing ever happens. I left it there for about 15 minutes to make sure it didn't just "run slower" in secure boot mode.

To make things more annoying, the hp P7-1417 does not have an HDD or DVD light so i can't tell if the computer is doing anything!

Does anybody know what I might be doing wrong here?

This new Windows 8/EFI thing is new and a total pain for us who want to use OUR computers OUR way! :confused:

January 3rd, 2013, 05:45 PM
Yeah, I am trying to stay as far away from UEFI, and as long as possible. Lets see how long I manage... :)

So, first thing first, from what I have read here, 12.04 is NOT secure boot compatible, so forget about it unless you can disable the secure boot. Can you? I'm not sure if that would affect win8 boot or not. First check the bios for an option to disable secure boot.

Also, only the 64bit version of ubuntu is UEFI compatible. You didn't specify but I'm guessing you are trying to install the 64bit. It won't work with the 32bit in any case, unless you convert the machine into legacy boot completely, including win8.

Further, in order to install ubuntu in uefi mode, you have to boot the cd/usb in uefi mode too. Otherwise it will simply install in legacy mode even though the machine is using uefi boot and you won't end up with uefi dual boot. Not sure if you are aware of this.
Uefi compatible machines come with two different boot devices for the dvd drive. One will be like UEFI DVD blahblah... and the other the good old legacy DVD device. You HAVE TO boot the uefi one.
I guess it would be much easier using the one time boot menu of the machine with F12 or similar button, rather than fishing all these new boot devices and their order in the bios.
If you didn't do this with the 12.10 attempt, maybe this was the issue.

To summarize, with secure boot enabled and win8 in uefi mode, you need to use the 12.10 64bit version and make sure you boot the cd in uefi mode.

If this is an Intel core machine and whether it has issues with the Intel HD graphics after you install, I have no idea about that. I stick with ATI. :)

PS EDIT: I read somewhere that the second point release of 12.04, the 12.04.2 will be secure boot compatible (since you said you prefer LTS version, I do too), but not sure if you can wait for it.

January 3rd, 2013, 05:55 PM

You are right, the UEFI bootable is only on 12.10 64-bit. I did not make it clear in my OP, that is the only reason I tried 12.10 64-bit, I would prefer 12.04 64-bit.

When I boot the install disc, I press Esc to bring up the boot menu, F9 for the boot device then select the "UEFI hp DVD<a bunch of numbers>" option.

I also read one way to tell if the installation disc is booting in EFI mode was if Grub pops up. If you get Grub then it is EFI and if you get the Ubuntu screen, it is legacy.

I will look into 12.04.02 64-bit for Ubuntu Studio. I really do not want to be doing this again in 2 years lol!

Edit/PS: It is an AMD based machine

January 3rd, 2013, 09:29 PM
If you have a fast boot or quick boot setting you want to turn that off. Some Samsung systems have a UEFI that only lets you back into UEFI menu from Windows with fast boot on. And if you cannot boot Windows then you have bricked entire system. But some Samsungs have installed ok.
UEFI boot live-usb bricks SAMSUNG 530U3C,np700z5c laptop - fix released

One HP install that worked.
HP p6-2326 Ubuntu and windows 8 Boot DVD

HP to get into UEFI/BIOS menu - escape then f10 as soon as it starts.

UEFI dual boot two drives - HP Windows 7

January 3rd, 2013, 10:02 PM

I forgot to mention, I did have Fast Boot disabled.

Thank you for the links, I will read through them and post back with what I get.

Thanks for the help!

January 4th, 2013, 02:33 AM
To make my OP clearer, when I boot the install CD, I get a Grub menu that says:

Try Ubuntu
Install Ubuntu
Check Disc for Errors

when I select any of the options the screen goes blank and nothing happens from there.

I have been able to install it in Legacy mode.

I have tried:
-Disabling Fast Boot
-Enabling Secure Boot
-Selecting Custom Keys (not HP Keys)
-Booting the DVD from the BIOS's boot menu
--Tried selecting each of the options from the GRUB menu (Try, Install, Check DVD)
-Loading the EFI manually

No matter how I try to boot the installer, I get a blank screen.

January 4th, 2013, 03:17 AM

I have downloaded 12.04.2 and tested, with the same results.

While doing so, I tried booting both 12.04.2 and 12.10 in legacy mode and they both will load the installer.

When I go back to the BIOS and enable secure boot, I get the blank screen after the DVD's grub menu.

And interesting side note, after I get this blank screen, Secure Boot, Legacy, and Fast Boot are ALL disabled.

January 4th, 2013, 03:32 AM
Ok sorry to be bombing my own thread.. but heres an update on the HP's UEFI..

I have determined that Secure Boot can only be enabled if I select HP keys under Key Ownership. If I select custom, it automatically disables Secure Boot.

I am using Version 2.15.1227 of American Megatrends Inc. EFI.

Could this be the reason it will not boot past the DVD's GRUB?

I don't have a clue where to go to begin fixing this!

January 4th, 2013, 05:13 PM
Another update,

To make things worse, Ubuntu doesn't load the Atheros R8161 Nic driver by default, so I can't get networking to run Boot-Repair on a LiveDVD, and Boot-Repair doesn't ship with Ubuntu Studio, even 12.10.

When I try to manually compile the driver from a LiveDVD I get an error that says "Cannot determine / from /etc/fstab"

Does anybody know why Boot-Repair REQUIRES internet!?

This is absolutely ridiculous!

January 4th, 2013, 05:33 PM
Sorry, I can't help much. As I said, I'm staying clear of UEFI and most of the things I know I have picked up here on the forum in other threads.

From what I have seen, there were couple of general rules:
1. Disable secure boot (not sure if it's necessary or only recommended).
2. Make sure you boot the ubuntu cd/usb in uefi mode.

The screen going black sounds like hardware issue. I don't mean faulty hardware, it just has some issue with some part of the hardware. On the other hand you say it boots the live mode fine in legacy boot. I can't see why it wouldn't do the same in uefi mode since if it is a hardware issue I would expect it to affect legacy mode too.

Try the uefi boot again, highlight the Try Ubuntu entry and hit 'e' for edit. Not sure if that will open the boot lines for editing as it does in legacy mode.

If it does, try adding acpi=off towards the end of the line starting with linux. I have seen it mentioned that acpi=off sometimes solves black screens.

Not sure how it would affect the machine though and whether you can sort it out later.

PS EDIT: When you say boot-repair requires internet, do you mean to install it or just to run it? For installing the package, it's clear why it needs internet because you are getting it from the repositories.
But for running it you shouldn't need internet. I think there is a bootable cd with boot-repair that you can use to boot and run boot-repair from it. I don't think you would need internet in that case.

January 4th, 2013, 05:41 PM

Thanks for the suggestion. I will give that a shot. I am at a loss for everything else.

I have tried installing with Secure Enabled and Disabled, Disabled is the only way I can get to the DVD's Grub menu, and Fast Boot and Legacy off.

In the boot menu, I select UEFI DVD, it will not let me select the Legacy options, since they are disabled.

Thank you so much for all your help, I will post back after I edit the boot optios!

PS To your Edit: I have ubuntu Rescue DVD and Boot-Repair says "Please connect to the internet. Continuing without internet will leave your system unbootable"

January 4th, 2013, 05:45 PM
It's probably getting the grub efi packages from the net to purge it and reinstall it, or something like that. So, you might be stuck running it without net.

January 4th, 2013, 05:47 PM
I did it anyway and got an unbootable system, ran my Windows 8 restore discs and called it a night...

January 4th, 2013, 05:56 PM
This is exactly what people were commenting when news started coming out about uefi, secure boot, and similar cr*p. That it will make dual booting hell. But no, MS said everything is fine, we are not trying to limit you to windows only... :)

On top of that, since years ago, they are not even giving you a DVD media with the OS you paid license for, only a useless restore partition. With a full windows DVD media, you can easily install it in legacy mode in 30mins.

You can try one thing, but you really shouldn't be wasting your time and energy doing any of this on a new machine that probably costed loads of money:
1. Make a windows rescue cd. There was one in win7, i hope there is in win8 too.
2. Then make a full backup of your win8. Separately, make a set of restore DVDs so that you have the original restore procedure when you delete the partition later.
3. Disable secure boot and uefi boot in bios.
4. Boot the machine with the ubuntu cd in live mode, create a new blank MSDOS table on the disk destroying all gpt partitions and table. Like it got faulty and you got a new disk. :) Create one ntfs partition on it with the size you want for the win8 system partition.
5. Restore the win8 backup to that partition. The tricky part is that the backup was from a uefi system, not legacy. And what type of boot files it has, or doesn't have.
6. If only boot files are missing, because it was in uefi boot earlier, the rescue cd should help restoring boot files and making it boot.

With any luck and a lot of wasted time, it might work. :)

After that there should be no problem installing ubuntu for legacy dual boot in the remaining of the hdd or depending how you want to organize it.

The trick is, should uefi backup work restored to legacy msdos partition???

January 4th, 2013, 06:00 PM
I just reread the documentation for Boot Repair and found this disk:

It looks like if I download #2 (Boot-Repair-Disk), it comes with everything I will need even if I do not have networking (as it doesn't support networking)! I'm going to give that a shot as well!
Edit to above..: Looks like it doesn't supprot WiFi devices not no networking :/ It's already burned so might as well give it a shot..

Edit: I'm going to try this disc, and if not, it looks like your dirty little way is my last resort. I had to purchase hp's recovery discs and created windows 8 restore discs..backed the entire hard drive up on an external, and luckily its a new machine so OS reinstalls aren't a ton of work restoring installed programs and data.

January 5th, 2013, 01:57 AM
Does anybody know why Boot-Repair REQUIRES internet!?


Probably you need a GRUB purge.

January 5th, 2013, 05:32 AM

Thank you for the link to answer my question.

Is there any reason a version of Grub can't "ship" with Ubunut-Recovery-Remix or the Boot-Repair CD's, and the CD be used as a repository?

I am asking out of pure ignorance.

January 5th, 2013, 06:10 AM
I give up on this thing.

hp and Microsoft ensured you cannot install an OS other than Windows8.

If you are looking for a computer and want to dual boot Windows and Linux, do not buy a P7-1417!


January 5th, 2013, 03:56 PM
Some mfgs have just made it more difficult, not sure if intentional or just they only think about Windows and do not care about any other use of computer.

Microsoft does require that you be able to turn secure boot off as part of their contract on secure boot with UEFI. And Ubuntu's version of grub2 with the 64 bit version of 12.10 actually is using the Windows key. But cheats a bit as it is called a shim to bridge from secure boot to grub.

Ubuntu has two versions of grub2 with 12.10. One is the standard BIOS boot grub-pc and the other is grub-efi. The version of grub-efi with older versions of Ubuntu has worked on UEFI without secure boot and the new version grub2 2.00 has worked with different vendors with secure boot systems.

If you accidentally install the BIOS version of Ubuntu, Boot-Repair will fix that by uninstalling grub-pc and installing grub-efi. But it needs an Internet connection (or you have to reconfigure to use DVD/Flash) to download grub-efi package. Many installs do not have the correct drivers for wireless, but almost all work with wired Ehternet so you can download the correct drivers.

January 6th, 2013, 02:05 AM
Is there any reason a version of Grub can't "ship" with Ubunut-Recovery-Remix or the Boot-Repair CD's, and the CD be used as a repository?

Good suggestion. AFAIK it is not possible to implement because Boot-Repair is designed to fix ALL versions of GRUB (whatever the GRUB version of the system to repair) so it would require to include many versions of GRUB (and all its dependencies, which are numerous) in the CD. Same problem when purging kernels. The Boot-Repair-Disk would not fit in a DVD any more...

January 6th, 2013, 04:50 AM

I don't know if it is on purpose or not but it sure seems like they're all out against me on this one LOL...

I have tried using a wired connection and still no internet! This thing is dead in the water, networking wise without Windows... (i guess dead in the water period without Windows!)


Thats what I figured, there were so many different Grubs tailored per machine that it would not be possible.

Thanks everybody for the help! I think after 2 weeks of wrestling with this, it is now at the point where it is impractical to try any more.

Now I need to find equivalent software that Ubuntu Studio offers that works on Windows...

January 6th, 2013, 03:54 PM
when I boot the install CD, I get a Grub menu that says:

Try Ubuntu
Install Ubuntu
Check Disc for Errors

when I select any of the options the screen goes blank and nothing happens from there.

I have been able to install it in Legacy mode.

I have tried:
-Disabling Fast Boot
-Enabling Secure Boot
-Selecting Custom Keys (not HP Keys)
-Booting the DVD from the BIOS's boot menu
--Tried selecting each of the options from the GRUB menu (Try, Install, Check DVD)
-Loading the EFI manually

No matter how I try to boot the installer, I get a blank screen.

You may need to add the 'nomodeset' option when booting: https://help.ubuntu.com/community/BootOptions#Changing_the_CD.27s_Default_Boot_Optio ns

Also, i don't understand when you say "No matter how I try to boot the installer, I get a blank screen.", because just before you said the contrary: "I have been able to install it in Legacy mode."

January 6th, 2013, 11:33 PM

I will try the nomodeset option.

What I meant was no matter what I try in UEFI, I get a blank screen after the DVD's Grub. If I run the disk in legacy, it goes through with the installation.

I thought it was bad to install an OS in legacy if Windows8 is installed in UEFI?

Also, it will not boot if I install in legacy, and since I cannot get networking on the LiveDVD to run Boot-Repair, I am screwed anyway...