PDA

View Full Version : 12.10 amd64 mouse too fast



Tares
December 29th, 2012, 04:16 PM
Hello,

I have problem with my Logitech G5. I can't make it slower. In xfce settings I have everything on the lowest possible values. I've tried also modifying xinput. Xinput output looks currently like this:

tares@tengoku:~$ xinput list-props 8
Device 'Logitech USB Gaming Mouse':
Device Enabled (139): 1
Coordinate Transformation Matrix (141): 1.000000, 0.000000, 0.000000, 0.000000, 1.000000, 0.000000, 0.000000, 0.000000, 1.000000
Device Accel Profile (268): 0
Device Accel Constant Deceleration (269): 1.000000
Device Accel Adaptive Deceleration (270): 1.000000
Device Accel Velocity Scaling (271): 0.100000
Device Product ID (257): 1133, 49225
Device Node (258): "/dev/input/event2"
Evdev Axis Inversion (272): 0, 0
Evdev Axes Swap (274): 0
Axis Labels (275): "Rel X" (149), "Rel Y" (150), "Rel Horiz Wheel" (266), "Rel Vert Wheel" (267)
Button Labels (276): "Button Left" (142), "Button Middle" (143), "Button Right" (144), "Button Wheel Up" (145), "Button Wheel Down" (146), "Button Horiz Wheel Left" (147), "Button Horiz Wheel Right" (148), "Button Side" (261), "Button Extra" (262), "Button Forward" (263), "Button Back" (264), "Button Task" (265), "Button Unknown" (260), "Button Unknown" (260), "Button Unknown" (260), "Button Unknown" (260), "Button Unknown" (260), "Button Unknown" (260), "Button Unknown" (260), "Button Unknown" (260), "Button Unknown" (260), "Button Unknown" (260), "Button Unknown" (260), "Button Unknown" (260)
Evdev Middle Button Emulation (277): 0
Evdev Middle Button Timeout (278): 50
Evdev Third Button Emulation (279): 0
Evdev Third Button Emulation Timeout (280): 1000
Evdev Third Button Emulation Button (281): 3
Evdev Third Button Emulation Threshold (282): 20
Evdev Wheel Emulation (283): 0
Evdev Wheel Emulation Axes (284): 0, 0, 4, 5
Evdev Wheel Emulation Inertia (285): 10
Evdev Wheel Emulation Timeout (286): 200
Evdev Wheel Emulation Button (287): 4
Evdev Drag Lock Buttons (288): 0


As for xorg.conf:

Section "InputDevice"
Identifier "LOGITECH G5"
Driver "mouse"
# Driver "evdev"
Option "CorePointer"
Option "Name" "Logitech USB Gaming Mouse"
Option "ZAxisMapping" "4 5 6 7"
Option "Emulate3Buttons" "false"
EndSection


I think I've tried every option I found on google, but no luck. Any help with be appreciated.

Best regards,
Tares

The Cog
December 29th, 2012, 04:18 PM
The sliders on the mouse settings work backwards - to the right makes the mouse slower. Sorry for the dumb answer if you already knew this - it took me a few minutes woth a new mouse yesterday to work that out.

Tares
December 29th, 2012, 04:27 PM
Thanks for the replay, but actually, sliders doesn't change anything. It doesn't matter if I have it min or max, mouse movement is the same.

The Cog
December 31st, 2012, 10:27 AM
I just found this:
http://patrickmylund.com/blog/lowering-gaming-mouse-sensitivity-in-ubuntu-9-10/
It works for me on 12.10.

I used these commands:

xinput --list --short
from which I could see that my mouse is named "OM".
Then:

xinput --set-prop "OM" "Device Accel Constant Deceleration" 2
The artlcle I linked suggested 5 but that made mine rather too slow.

Tares
January 1st, 2013, 06:34 PM
As I stated in my first post, I've already tried modyfing configuration using xinput.

The Cog
January 2nd, 2013, 03:55 PM
I see in your first post that you haven't changed "Device Accel Constant Deceleration" from its default value of 1.

Tares
January 3rd, 2013, 12:30 AM
Okay. My mistake. "Deceleration" has to be set to higher value. I tried to put 0.1 but doesn't allow this value and I just skipped it.

Now I've changed it to 4 and the mouse feels okay. Thanks for your help.

The Cog
January 3rd, 2013, 07:17 PM
Excellent.
I'm surprised that it didn't allow 0.1, but since lower numbers mean faster, that would have made the mouse completely unusable!