View Full Version : Failing to Boot Ubuntu from USB3 on Toshiba Ultrabook Z935

December 28th, 2012, 06:34 PM
Hi everyone,

Sorry for the amateur-ish question... but I would be very grateful for some help!!

I am trying to boot Ubuntu 12.10 from USB3 on my Toshiba Ultrabook Z935 in order to install it alongside Windows 8. But I can't get it to boot from the usb! :-(

Naturally, the first thing I did was change the boot order in the BIOS so the USB memory is first. But when it didn't make a difference, I started researching what the problem could be and I've tried everything I came across and I still can't get it to boot.

I disabled the secure boot, and after a few other changes in the bios, I finally disabled the USB legacy emulation. The latter resulted in "preparing automatic repair" on the Toshiba startup screen and nothing else. All other changes kept booting me into windows. I read a few different things, but so far nothing is working for me.

Thanks so much,

December 28th, 2012, 07:55 PM
Welcome to the forums.

With Windows 8 you do have to turn off secure boot and really need to turn off any fast boot or quick boot type settings.

Once secure boot is off you should then in UEFI menu have the option to boot the flash drive.

But flash drive does have to be bootable or Ubuntu has to be installed to it not just the ISO copied to it.

I know on older systems some has issues booting from USB3 ports. Do you have any USB2 ports? New UEFI should work.

Also some have had issues with certain flash drives or different USB creators. Some have just used a different flash drive, or used a different USB creator or downloaded it again as first download was not ok. Did you check md5sum?

Also instructions for CD/DVD or USB
Write image or burn image not copy ISO as one large file to CD.


Standard instructions are in link above for installing to flash drive from Windows. Other alternatives.
If that does not work

December 29th, 2012, 03:10 AM
Thanks OldFred!

I do have USB2 and neither USB2 nor USB3 made a difference. On another blog, someone who successfully installed Ubuntu on their Z930 said that USB2 doesn't work and that I have to use USB3. (http://yltechblog.blogspot.com/2012/09/installing-ubuntu-1204-to-toshiba-z930.html) Unfortunately, I didn't get the answers I was looking for.

The USB stick I am using is bootable and has been used to install Ubuntu on another machine. And md5sum has been checked.

Still nothing... :-(


December 29th, 2012, 05:37 AM
Is your install the 64 bit version of 12.10. That is the only one that supports secure boot with Windows 8.

Or do you get past boot and have video type issues.

Is this a Ultrabook with the small SSD? That complicates it, but several have posted how to do it. Some prefer Ubuntu and just install its / (root) to the SSD, other install to the hard drive. But you have to turn the Intel SRT off and maybe remove the RAID settings.

Standard UEFI installs, best to review first.
You will need to use the 64 bit version of 12.10 and from the UEFI menu boot the flash drive in UEFI mode. That way it will install in UEFI mode.
Systems need quick boot or fast boot turned off in UEFI settings.

Then Intel SRT, basically the same for all vendors:

Intel Smart Response Technology
Some general info in post #3
ubuntu 12.10 & Windows 8 oem Sony T & Intel SRT
Intel SRT - Dell XPS
Details in post #10 on an install that worked
Dell XPS Intel SRT issue on hibernating post #25
Some info on re-instating details in post #9

Disable the RAID, for me it was using the Intel rapid management thingy and telling it to disable the acceleration or the use of the SSD. If you have a different system, just disable the RAID system then install Ubuntu. Once installed you can then re-enable it.

You will need to use the dmraid command prior to running the Ubuntu Installer so that it will be able to see the partitions on the drive because otherwise with the raid metadata in place it will see the drive as part of a raid set and ignore its partitions.From 2011, so now older

December 30th, 2012, 11:50 PM
It seems the USB is carrying the 32 bit version although I thought it was 64. Installation on old machine vs new machine confusion. I will try with the 64 bit version. Hopefully, this is the problem and we'll be OK.

I'll keep you posted!

Thanks for now!


December 31st, 2012, 03:21 AM
Thank you OldFred!

The 32bit installation was the problem!!

We finally booted successfully! LOL


December 31st, 2012, 05:34 AM
Glad that worked. :)