View Full Version : [ubuntu] LO 3.5 does not remove completely

December 23rd, 2012, 04:21 AM
Was checking my system for odd things, and came across the following:
Dash Home -> Installed shows an generic icon with the text: LibreOffice 3.5 Math.
This was strange, because I am running: LO on Ubuntu 12.04.
The icon LibreOffice 3.6 Math did not show. It does run from the Suite, however.

After some looking into it, I found that under /opt, there was still a folder with the name: libreoffice3.5.
I ran:

sudo apt-get purge libreoffice*
sudo apt-get autoremove
sudo apt-get remove
sudo apt-get update
sudo apt-get clean

None of the above removed the folder, and the generic icon.
So, I ran: sudo nautilus, and removed it manually.
Interesting result: nothing changed. The icon was still there.
After some research on the internet, Ask Ubuntu gave a potential solution, being: unity --reset. I logged in under gnome, and in the terminal I typed: unity --reset. It did not do what I expected, because it appeared to be hanging. After 10 minutes I killed the process.

Ok, me thinking simple. Re-install the LO 3.5 version, and remove it again. Hopefully that works, so I re-installed LO 3.5.7.
After the installation, the Dash Home -> Installed showed a proper icon for the LO 3.5 Math, and it also worked.
Ok, now, remove it again, using the same list as above, starting with purging.
Big :confused::cry::sad:. EVERYTHING IS THE SAME AS BEFORE.
The generic icon is back.

Me not understand anymore.

Can anyone shed some light on this one?


Hylas de Niall
December 23rd, 2012, 08:43 AM
I always use

sudo apt-get remove --purge libreoffice-core

It seems to work okay for me :)


December 23rd, 2012, 09:36 AM
I always use

sudo apt-get remove --purge libreoffice-coreIt seems to work okay for me :)


Interestingly the core is not installed?
I use the debs from libreoffice.org directly to install.


January 6th, 2013, 06:49 AM

Please help.