View Full Version : Problem with Fortran, psosible issue with PATH

December 18th, 2012, 06:15 AM
Hello there, I hope my message will get read soon and somebody will give me a solution.
I use fortran to do simulation and gfortran is the compiler I use. Recently I migrated from Ubuntu 10.10 to 12.10. After installing gfortran then I tried to compile and run my fortran programs then the problem started. I succsesfully compiled the program but unable to execute it. (I work in a directory in shared partition, not in HOME directory). When I compiled the program and run it within HOME directory, everything worked fine. On my Ubuntu 10.10, I was able to compile and execute fortran program from every where not only within HOME directory.
This is what I do for compiling and executing fortran program:
gfortran hello.f90 -o hello # to compile it
./hello # to execute it

I'm blind about PATH or anything like it (this has to do with it, I suspect) so please give me direction.
Many thanks.

December 18th, 2012, 02:57 PM
Thread moved to Programming Talk.


Tony Flury
December 18th, 2012, 03:20 PM
What is the actual error you get ?
Is the shared partition an entirely Ubuntu partition, or is it for instance a shared Samba drive ?