PDA

View Full Version : [lubuntu] Numlock bug after resume



netrick
December 10th, 2012, 08:30 PM
So, when I suspend my pc (sleep, don't know how to translate it, but it's not hibernate but the second option, with ram being powered) and then resume it, I have a very strange behaviour.
Before suspending, I have numlock turned on. I suspend it then I resume my pc. Then, here is the bug:
- numpad is working, from software-side numlock is enabled
- BUT on my keyboard, numlock LED is turned off

It isn't critical bug, but it looks a bit strange and I'd prefer to have that numlock behave correctly when suspending.

I'm using lubuntu 12.10.

Thanks

Statia
December 10th, 2012, 09:18 PM
Same bug here in Kubuntu 12.04.
Numlock is on, but the light isn't. Pushing it twice fixes it: first time nothing happens (I turn of a light that is already off), second time it comes on.
Related: after resuming from sleep I have to run the script again to make my winkey call the KDE-menu. Script is located in ~/.kde/Autostart.

netrick
December 10th, 2012, 10:40 PM
Yes, I have the same behaviour with pressing it 2 times to get led working.
Is this bug known to devs?

edit:
I use numlockx to have numlock enabled after boot. I guess there should be something done that start-up scripts are executed after resume.

Statia
December 12th, 2012, 10:36 PM
Is this bug known to devs?


I never found this important enough to file a bug report for or check if there is an existing bug report, but I did post about it here before.

netrick
December 15th, 2012, 10:28 PM
I think I know how to solve it. There are resume scripts in linux and we just need to put numlockx there to execute (maybe 2 times?). But I don't know anything how to find this script, do you have any clue?