PDA

View Full Version : Black background on Overview Gnome-shell 3.6.2.



serdotlinecho
November 27th, 2012, 04:22 PM
Is this a default feature, black overview background on gnome-shell 3.6.2?

C@illou
December 2nd, 2012, 02:12 PM
Hi,

I have the exact same problem, a black background on Overview since I upgraded to Gnome 3.6.2, instead of having the greyed/shadowed desktop background. But sometimes it's working as expected, and it seems to mess up when I plug a second screen to my laptop. If it can be related to my graphic card, I have an Intel HD4000 integrated to the CPU.

EDIT: It's working fine when I juste booted, but as soon as I plug my external monitor, the oveview background is black.

serdotlinecho
December 2nd, 2012, 05:22 PM
But for me just black background, as i'm now using default ubuntu wallpaper and stock gnome-shell theme but still showing black background. I think it should show my wallpaper as a background.

VinDSL
December 3rd, 2012, 03:21 AM
In my experience, changing your Shell Theme will make a huge difference.

I'm running GS 3.7.2...

Here's how it looks with the Default Shell Theme



http://vindsl.com/images/vindsl-desktop-2-dec-2012-6(650x520).png (http://vindsl.com/images/vindsl-desktop-2-dec-2012-6.png)


If I had a solid dark wall, instead of gradient greys, I'd be straining my eyeballs.

Now, here's the-same-everything, but I'm using "Elementary" for the Shell Theme



http://vindsl.com/images/vindsl-desktop-2-dec-2012-7(650x520).png (http://vindsl.com/images/vindsl-desktop-2-dec-2012-7.png)


Big difference, eh what? ;)

serdotlinecho
December 3rd, 2012, 06:46 AM
I use guayadeque too because it's lightweight and fast on my netbook :guitar:
but on gnome-shell it doesn't show appmenu? Hmmm nevermind, I still love and use Unity. I hate gnome-shell big bottom system tray. Like when I want to use screencloud app and it's hidden at the bottom and really slow to access ](*,) where on Unity, it's there for me at the top panel, click and show drop down menu/settings! Fast!

atreiju
December 13th, 2012, 10:36 AM
I have the same problem with the black background! And it doesn't depened on the theme I'm using. For me, it looks like it has something to do with the opacity in the overview.

I can deactivate every extension (themes, too), and I still get the same black background.

Also, sometimes I do not have that "blackground" for a while, but after a short time, it's there again. Mostly it's there.

I also have an intel gpu.

Any ideas about this?

serdotlinecho
December 21st, 2012, 03:59 AM
Still having the same bug with gnome-shell 3.7.3
Here's a video: http://www.youtube.com/watch?v=mJlSI7Y4Lk0&feature=youtu.be

Update: After installing ubuntu gnome desktop package, i have solved the problem, thanks to grahammechanical!

VinDSL
December 21st, 2012, 09:44 AM
Still having the same bug with gnome-shell 3.7.3 [...]
Where did you find GS 3.7.3?!?!?

Gotta say, 3.7.2 is looking pretty sexy... ;)



http://vindsl.com/images/vindsl-desktop-21-dec-2012-1(650x520).png (http://vindsl.com/images/vindsl-desktop-21-dec-2012-1.png)

jeremi.thebeau
April 8th, 2013, 01:56 PM
Still having the same bug with gnome-shell 3.7.3
Here's a video: http://www.youtube.com/watch?v=mJlSI7Y4Lk0&feature=youtu.be

Update: After installing ubuntu gnome desktop package, i have solved the problem, thanks to grahammechanical!

Hi,

The video doesn't seem to be there anymore. I'm having this problem at the moment after updating my intel packages with the new intel graphic UI installer (https://01.org/linuxgraphics/downloads/2013/intel-linux-graphics-installer). Everything seems to be ok except that the normal semi-transparent overview overlay seem to be opaque.

I've intalled the ubuntu-gnome-desktop pakage(s) and reboot but still getting the same.

@ serdotlinecho, would you mind elaborating or explaining what grahammechanical is?

thanks

dafero
April 9th, 2013, 03:57 AM
Hi, The video doesn't seem to be there anymore. I'm having this problem at the moment after updating my intel packages with the new intel graphic UI installer (https://01.org/linuxgraphics/downloads/2013/intel-linux-graphics-installer). Everything seems to be ok except that the normal semi-transparent overview overlay seem to be opaque. Same here, right after updating the Intel driver, the Activities background turned black. I am using Ubuntu 12.10 + GS 3.6.2. Any ideas? Thank you!

ft_
April 9th, 2013, 05:40 AM
sorry, not a lot of time :
1) try reselect your background image
2) use lightdm instead of gdm for normal background
3) use lightdm instead of gdm for non-buggy multi-screen behaviour when unplugging the monitor
just my experience, dont blame me :-)

Kelkar
April 9th, 2013, 05:14 PM
I have the same problem as mentioned above. :(

Kelkar
April 10th, 2013, 09:59 PM
Ok, I finally found a solution for the black background bug. Just update your system to Ubuntu 13.04 and it should get back to normal.

zika
April 11th, 2013, 06:36 AM
Ok, I finally found a solution for the black background bug. Just update your system to Ubuntu 13.04 and it should get back to normal.All of us here are on 13.04... Mostly from the very beginning of the cycle or even before that... ;)

dafero
April 11th, 2013, 04:17 PM
Ok, I finally found a solution for the black background bug. Just update your system to Ubuntu 13.04 and it should get back to normal.

I don't wanna update, Ubuntu 13.04 is still a beta... is it the only solution?

zika
April 11th, 2013, 06:33 PM
I don't wanna update, Ubuntu 13.04 is still a beta... is it the only solution?Then You will be better asking this question outside this U+1 room...

Xgen
April 11th, 2013, 08:39 PM
Seems to work with.....gnome-tweak-tool-->Desktop-->Have file manager handle the desktop-->off. There are consequences, such as no context menu on the desktop and probably others. As a side note, wallpaper dimming works for me without modifications on gnome-shell 3.8.

Merri
June 20th, 2013, 04:15 PM
Seems to work with.....gnome-tweak-tool-->Desktop-->Have file manager handle the desktop-->off. There are consequences, such as no context menu on the desktop and probably others. As a side note, wallpaper dimming works for me without modifications on gnome-shell 3.8.


Ah thanks for this tip! Toggling this option on and off a few times fixed the problem for me without having to leave it disabled all the time. I'm running 13.04 with Gnome 3.6.3.

C@illou
June 21st, 2013, 11:06 AM
Seems to work with.....gnome-tweak-tool-->Desktop-->Have file manager handle the desktop-->off. There are consequences, such as no context menu on the desktop and probably others. As a side note, wallpaper dimming works for me without modifications on gnome-shell 3.8.

I had to do the same thing to get the background back to normal on Archlinux + Gnome, seems like having file manager handling the desktop breaks the wallpaper in the overview. Thanks.

Kow
June 23rd, 2013, 10:29 PM
I was trying out debian testing a few days ago and had this problem sporadically. If I logged-out and logged back in the background would appear. I guess the important thing here is that this is probably an upstream issue.

cariboo
June 23rd, 2013, 11:23 PM
I was trying out debian testing a few days ago and had this problem sporadically. If I logged-out and logged back in the background would appear. I guess the important thing here is that this is probably an upstream issue.

You should check out phillinux's post here (http://ubuntuforums.org/showthread.php?t=2142381&p=12701768&viewfull=1#post12701768), it links to an explanation to what the Ubuntu devs have done to solve the problem.